REBOOT(8) BSD System Manager's Manual (SPARC Architecture) REBOOT(8)
reboot - UNIX bootstrapping procedures
reboot [-n] [-q]
Power fail and crash recovery. Normally, the system will reboot itself at
power-up or after crashes. An automatic consistency check of the file
systems will be performed as described in fsck(8). and unless this
fails, the system will resume multi-user operations.
Cold starts The SPARC system currently uses the SunOS bootstrap loaders.
This will be changed in a future version of the system. The SunOS boot
will attempt to load vmunix from partition A of the boot device, which
must currently be an ``sd'' disk.
The [-s] flag to the SunOS boot loader will being the system up in sin-
gle-user mode. The [-d] flag to the SunOS boot loader will bring the
system up in debug mode. Here it waits for a kernel debugger connect;
see kgdb(8). Other flags are currently ignored.
/vmunix system code
/boot system bootstrap
crash(8), disklabel(8), fsck(8), halt(8), init(8), rc(8),
The use of Sun disk labels, without the ability to write them, is prob-
4.4BSD April 19, 1994 1