BGPD(8) OpenBSD System Manager's Manual BGPD(8)
bgpd - Border Gateway Protocol daemon
bgpd [-dnv] [-D macro=value] [-f file]
bgpd is a Border Gateway Protocol (BGP) daemon which manages the network
routing tables. Its main purpose is to exchange information concerning
"network reachability" with other BGP systems. bgpd uses the Border
Gateway Protocol, Version 4, as described in RFC 1771. Please refer to
that document for more information about BGP.
bgpd is usually started at boot time, and can be enabled by setting the
following in /etc/rc.conf.local:
See rc(8) and rc.conf(8) for more information on the boot process and en-
When bgpd starts up, it reads settings from a configuration file, typi-
cally bgpd.conf(5). A running bgpd process can be controlled using the
The options are as follows:
Define macro to be set to value on the command line. Over-
rides the definition of macro in the configuration file.
-d Do not daemonize. If this option is specified, bgpd will run
in the foreground and log to stderr.
-f file Use file as the configuration file, instead of the default
-n Configtest mode. Only check the configuration file for va-
-v Produce more verbose output.
/etc/bgpd.conf default bgpd configuration file
A Border Gateway Protocol 4 (BGP-4), RFC 1771, March 1995.
BGP Communities Attribute, RFC 1997, August 1996.
Protection of BGP Sessions via the TCP MD5 Signature Option, RFC 2385,
BGP Route Flap Damping, RFC 2439, November 1998.
Multiprotocol Extensions for BGP-4, RFC 2858, June 2000.
Route Refresh Capability for BGP-4, RFC 2918, September 2000.
Capabilities Advertisement with BGP-4, RFC 3392, January 1999.
NOPEER Community for Border Gateway Protocol, RFC 3765, April 2004.
The bgpd program first appeared in OpenBSD 3.5.
OpenBSD 3.6 December 22, 2003 2