ATMARPD(8) BSD System Manager's Manual ATMARPD(8)
atmarpd -- ATMARP/SCSP interface daemon
atmarpd [-d] [-l <log_file>] <net_intf> ...
The atmarpd utility provides an interface between the ATMARP server in
the kernel and the SCSP daemon for the Host ATM Research Platform (HARP)
networking software. The atmarpd utility reads the ATMARP cache from the
kernel periodically and passes any updated entries to scspd(8) so they
will be propagated to remote servers. It also accepts updated entries
that remote servers have sent to scspd(8) and, if they are new or more up
to date than current entries, installs them in the kernel's ATMARP cache.
Both atmarpd and scspd(8) must be running before any ATMARP cache syn-
chronization can take place.
When atmarpd starts, it parses its command line and puts itself into the
The command-line options are:
-l <log_file> Specify that atmarpd is to write log messages to the file
named <log_file> rather than to the system log.
-d Specify that atmarpd is to be run in debug mode. In debug
mode, atmarpd is not put into the background. Log mes-
sages are written to standard output instead of to the log
<net_intf> Specify the network interface(s) for which the host is
providing ATMARP service and whose caches are to be syn-
chronized using SCSP. If multiple network interface names
are specified, atmarpd will provide an interface to
scspd(8) for the servers on all the specified interfaces.
The following signals can be used to control atmarpd:
SIGINT Dump debugging information to a file. When it receives a SIGINT
signal, atmarpd dumps a summary of its control blocks to a text
file (see FILES).
Debugging information dump file name. The atmarpd utility writes
a summary of its control blocks to this file when it receives a
SIGINT signal. <pid> is the process ID of the daemon and <seq>
is a sequence number which is incremented every time a dump is
Classical IP and ARP over ATM, RFC 1577.
Classical IP and ARP over ATM, RFC 2225.
Server Cache Synchronization Protocol (SCSP), RFC 2334.
A Distributed ATMARP Service Using SCSP,
Results are unpredictable if multiple instantiations of atmarpd are run
simultaneously for a given network interface.
Please report any bugs to <harp-bugsATmagic.net>.
Copyright (c) 1994-1998, Network Computing Services, Inc.
John Cavanaugh, Network Computing Services, Inc.
Mike Spengler, Network Computing Services, Inc.
Joe Thomas, Network Computing Services, Inc.
This software was developed with the support of the Defense Advanced
Research Projects Agency (DARPA).
BSD August 4, 1998 BSD