ATACTL(8) BSD System Manager's Manual ATACTL(8)
atactl -- a program to manipulate ATA (IDE) devices
atactl device command [arg [...]]
atactl allows a user or system administrator to issue commands to and
otherwise control devices which reside on standard IDE and ATA con-
trollers. It is used by specifying a device to manipulate, the command
to perform, and any arguments the command may require.
The following commands may be used on IDE and ATA devices. Note that not
all devices support all commands.
Identify the specified device, displaying the device's vendor, product,
revision strings, and the device's capabilities.
Place the specified device into Idle mode. This mode may consume less
power than Active mode.
Place the specified device into Standby mode. This mode will consume
less power than Idle mode.
Place the specified device into Sleep mode. This mode will consume less
power than Standby mode, but requires a device reset to resume operation.
Typically the wd(4) driver performs this reset automatically, but this
should still be used with caution.
Places the specified device into Idle mode, and sets the Idle timer to
idle-timer seconds. A value of 0 will disable the Idle timer.
Places the specified device into Standby mode, and sets the Standby timer
to standby-timer seconds. A value of 0 will disable the Standby timer.
Will print out if the device is in Active, Idle, or Standby power manage-
smart [enable | disable | status | selftest-log]
Controls SMART feature set of the specified device. SMART stands for
Self-Monitoring, Analysis, and Reporting Technology. It provides an
early warning system by comparing subtle operation characteristics to
those determined in vendor testing to precede device failures.
Enables access to SMART capabilities within the device. Prior to being
enabled, a SMART capable device neither monitors nor saves SMART
attribute values. The state of SMART, either enabled or disabled, will
be preserved by the device across power cycles.
Disables access to SMART capabilities within the device. Attribute val-
ues will be saved, and will no longer be monitored.
Reports whether SMART is supported by the device, and whether SMART is
enabled on the device (can only be determined on ATA6 or better devices).
If SMART is enabled, then a table of attribute information is printed.
Attributes are the specific performance or calibration parameters that
are used in analyzing the status of the device. The specific set of
attributes being used and the identity of these attributes is vendor spe-
cific and proprietary.
Attribute values are used to represent the relative reliability of indi-
vidual performance or calibration parameters. The valid range of
attribute values is from 1 to 253 decimal. Lower values indicate that
the analysis algorithms being used by the device are predicting a higher
probability of a degrading or faulty condition.
Each attribute value has a corresponding threshold limit which is used
for direct comparison to the attribute value to indicate the existence of
a degrading or faulty condition. The numerical value of the attribute
thresholds are determined by the device manufacturer through design and
reliability testing and analysis. Each attribute threshold represents
the lowest limit to which its corresponding attribute value can equal
while still retaining a positive reliability status.
If the crit field is "yes" then negative reliability of this attribute
predicts imminent data loss. Otherwise it merely indicates that the
intended design life period of usage or age has been exceeded. The col-
lect field indicates whether this attribute is updated while the device
is online. The reliability field indicates whether the attribute value
is within the acceptable threshold.
selftest-log Print the selftest log.
The atactl command first appeared in NetBSD 1.4.
The atactl command was written by Ken Hornstein. It was based heavily on
the scsictl(8) command written by Jason R. Thorpe.
The output from the identify command is rather ugly.
BSD December 20, 2003 BSD