ASF(8) BSD System Manager's Manual ASF(8)
asf -- add symbol files
asf [-afksx] [modules-path [outfile]]
By default, asf reads kldstat(8) output from standard input and writes to
standard output a list of gdb(1) commands to add symbol files from KLDs
in subdirectories of the subdirectory modules of the current directory,
which is intended to be a kernel build directory. This allows gdb(1) to
load the symbols into the debugging environment.
If modules-path is specified, asf uses it for the modules directory
instead of the default modules. This is useful when building in a non-
standard location (i.e., not /usr/src and /usr/obj).
If outfile is specified, asf writes to it instead of standard output.
The following options modify the function of asf:
-a When writing to an explicit outfile, append to the file rather
than overwriting it.
-f Instead of trying to simplistically guess the path for each mod-
ule, perform a traversal in the same way that find(1) does to
locate an exact path for each module, no matter where in
modules-path it is located.
-k Instead of reading from standard input, start a kldstat(8) and
read the information from it.
-s Do not prepend a (guessed) subdirectory of the module path.
-x Normally asf looks for KLDs with names of the form
<module>.ko.debug. The -x option tells asf to look for KLDs with
names of the form <module>.ko.
The asf utility first appeared in FreeBSD 5.2.
Greg Lehey <grogATFreeBSD.org>
It should be possible to write to an outfile without specifying a module
BSD June 8, 2003 BSD