ARP(8) OpenBSD System Manager's Manual ARP(8)
arp - address resolution display and control
arp [-n] hostname
arp [-n] -a
arp -d hostname
arp -d -a
arp -s hostname ether_addr [temp | permanent] [pub]
arp -f filename
The arp program displays and modifies the Internet-to-Ethernet address
translation tables used by the address resolution protocol (arp(4)).
With no flags, the program displays the current ARP entry for hostname.
The host may be specified by name or by number, using Internet dot nota-
-a Display all of the current ARP entries. See also the -d option
-d Delete an entry for the host called hostname. Alternatively, the
-d flag may be combined with the -a flag to delete all entries,
with hostname lookups automatically disabled. Only the superuser
may delete entries.
Process entries from filename to be set in the ARP tables. En-
tries in the file should be of the form:
hostname ether_addr [temp | permanent] [pub]
The entry will be static, i.e., will not time out, unless the
word temp is given in the command. A static ARP entry can be
overwritten by network traffic, unless the word permanent is giv-
en. If the word pub is given, the entry will be ``published'';
i.e., this system will act as an ARP server, responding to re-
quests for hostname even though the host address is not its own.
This behavior has traditionally been called proxy ARP.
-n Show network addresses as numbers (normally arp attempts to dis-
play addresses symbolically).
-s hostname ether_addr
Create an ARP entry for the host called hostname with the Ether-
net address ether_addr. The Ethernet address is given as six
hexadecimal bytes separated by colons.
The permanent, pub, or temp modifiers may be specified with mean-
ings as given above.
To view the current arp(4) table:
$ arp -a
To create a permanent entry (one that cannot be overwritten by other net-
# arp -s 10.0.0.2 00:90:27:bb:cc:dd permanent
To create proxy ARP entries on an interface, fxp0, for the IP addresses
188.8.131.52 and 184.108.40.206:
# arp -s 220.127.116.11 00:90:27:bb:cc:dd pub
# arp -s 18.104.22.168 00:90:27:bb:cc:dd pub
(where 00:90:27:bb:cc:dd is the MAC address of fxp0)
inet(3), arp(4), ifconfig(8)
The arp command appeared in 4.3BSD.
OpenBSD 3.6 July 14, 1999 2