ARLCONTROL(8) BSD/i386 System Manager's Manual ARLCONTROL(8)
arlcontrol -- configure Aironet Arlan 655 device
arlcontrol iface country country (9-15)
arlcontrol iface priority priority (normal, high, highest)
arlcontrol iface txretry txretry
arlcontrol iface stat
arlcontrol iface quality
The arlcontrol utility controls the operation of Aironet Arlan 655 wire-
less networking devices via the arl(4) driver. Most of the parameters
that can be changed are related to the Aironet protocol which the Aironet
Arlan 655 card implements. The arlcontrol utility can also be used to
view the current NIC status, configuration, and to dump out the values of
the card's statistics counters.
The iface argument given to arlcontrol should be the logical interface
name associated with the Aironet Arlan 655 device (arl0, arl1, etc.) and
must be specified.
The options are as follows:
iface Display current settings of the specified wireless interface.
This retrieves current card settings from the driver and prints
iface country country (9-15)
Chose country, channel parameters that depend on the country
according to the following table:
Country Ch_Set MHz
North America 9 2412, 2427, 2442, 2457, 2465
U.S.A 9 2412, 2427, 2442, 2457, 2465
Canada 9 2412, 2427, 2442, 2457, 2465
Mexico 9 2412, 2427, 2442, 2457, 2465
New Zealand 9 2412, 2427, 2442, 2457, 2465
E.T.S.I 10 2412, 2427, 2442, 2457, 2472
Japan 11 2484
France 12 2457, 2465, 2475
Australia 13 2411, 2425, 2439
Germany 14 2427, 2442, 2457
U.K.(MPT1349) 15 2460
U.K. 15 2460
Spain 15 2460
iface priority priority (normal, high, highest)
Use the priority parameter to set the priority of the Arlan 655
Radio Media Access Control the values are normal, high or
highest. The higher the priority is set, the more likely this
unit will be the first to successfully transmit a packet when
multiple units are trying to transmit at the same time.
The percentage of units on your network that you set to values
other than normal should be kept small - 10 percent or less.
iface txretry txretry
Set transmit retries. Default is 0.
Print internal Arlan 655 statistics block.
Display the cached signal level and quality maintained by the
arl(4) driver. The driver retains information about quality and
level for packets received from different hosts. Also the driver
extracts values from ACK packets.
arlcontrol arl0 country 11 priority high
arlcontrol arl0 quality
arlcontrol arl0 stat
You can configure the Arlan 655 card from /etc/start_if.arl0. For exam-
/usr/sbin/arlcontrol country 9 priority highest
Arlan 655 ISA Wireless LAN Client Card User Guide.
The arlcontrol utility first appeared in FreeBSD 5.3.
Aironet Arlan 640 bridges and Arlan 630 access points do not understand
country codes other than 9.
The arlcontrol utility was written by <ranATstyx.net>. This manpage
was written by Yuri Kurenkov <y.kurenkovATinit.ru>.
BSD March 15, 2004 BSD