AMQ(8) OpenBSD System Manager's Manual AMQ(8)
amq - automounter query tool
amq [-f] [-h hostname] [-m] [-s] [-u] [-v] [directory] ...
amq provides a simple way of determining the current state of the amd(8)
program. Communication is by RPC. Three modes of operation are support-
ed by the current protocol. By default a list of mount points and auto-
mounted filesystems is output. An alternative host can be specified us-
ing the -h option.
If directory names are given, as output by default, then per-filesystem
information is displayed.
The options are as follows:
-f Request automounter to flush the internal caches.
Query alternate host hostname. By default the local host is
used. In an HP-UX cluster, the root server is queried by de-
fault, since that is the system on which the automounter is nor-
-m Request the automounter to provide a list of mounted filesystems,
including the number of references to each filesystem and any er-
ror which occurred while mounting.
-s Request the automounter to provide system-wide mount statistics.
-u Request the automounter to unmount the named filesystems instead
of providing information about them. Unmounts are requested, not
forced. They merely cause the mounted filesystem to timeout,
which will be picked up by amd's main scheduler thus causing the
normal timeout action to be taken.
-v Request the automounter to provide version information. This is
a subset of the information provided by amd's -v option.
amq.x RPC protocol description
Jan-Simon Pendry <jspATdoc.uk>, Department of Computing, Imperial
College, London, UK.
amq uses a Sun registered RPC program number (300019 decimal) which may
not be in the /etc/rpc database.
OpenBSD 3.6 March 16, 1991 1