AMQ(8) BSD System Manager's Manual AMQ(8)
amq -- automounter query tool
amq [-fmpsuvTU] [-h hostname] [-l log_file] [-x log_options]
[-D debug_options] [-M mountmap_entry] [-P program_number]
Amq provides a simple way of determining the current state of the amd(8)
program. Communication is by RPC. Three modes of operation are sup-
ported by the current protocol. By default a list of mount points and
auto-mounted file systems is output. An alternative host can be speci-
fied using the -h option.
If directory names are given, as output by default, then per file system
information is displayed.
-f Request automounter to flush the internal caches.
Query alternate host hostname. By default the local host is
used. In an HP-UX cluster, the root server is queried by
default, since that is the system on which the automounter is
Tell amd to use log_file as the log file name. For security rea-
sons, this must be the same log file which amd used when started.
This option is therefore only useful to refresh amd's open file
handle on the log file, so that it can be rotated and compressed
via daily cron jobs.
-m Request the automounter to provide a list of mounted file sys-
tems, including the number of references to each file system and
any error which occurred while mounting.
-p Return the process ID of the remote or locally running amd. Use-
ful when you need to send a signal to the local amd process, and
would rather not have to search through the process table. This
option is used in the ctl-amd script.
-s Request the automounter to provide system-wide mount statistics.
-u Request the automounter to unmount the named file systems instead
of providing information about them. Unmounts are requested, not
forced. They merely cause the mounted file system to timeout,
which will be picked up by amd's main scheduler thus causing the
normal timeout action to be taken.
-v Request the automounter to provide version information. This is
a subset of the information provided by amd's -v option.
Ask the automounter to use the logging options specified in
log_options from now on.
Ask the automounter to use the debugging options specified in
debug_options from now on.
-M Pass a mount map entry to amd and wait for it to be evaluated,
possibly causing a mount. This option is highly insecure. By
default, amd and amq do not support it. It is necessary to con-
figure am-utils with --enable-amq-mount to enable this option.
Contact an alternate running amd that had registered itself on a
different RPC program_number and apply all other operations to
that instance of the automounter. This is useful when running
multiple copies of amd, and need to manage each one separately.
If not specified, amq will use the default program number for
amd, 300019. For security reasons, the only alternate program
numbers amd can use range from 300019 to 300029, inclusive.
-T Contact amd using the TCP transport only. Normally amq will try
TCP, and if that fails, will try UDP.
-U Contact amd using UDP (connectionless) transport only. Normally
amq will try TCP, and if that fails, will try UDP.
amq.x RPC protocol description.
Amq uses a Sun registered RPC program number (300019 decimal) which may
not be in the /etc/rpc database.
Jan-Simon Pendry <jspATdoc.uk>, Department of Computing, Imperial
College, London, UK.
Erez Zadok <ezkATcs.edu>, Department of Computer Science, Colum-
bia University, New York, USA.
Other authors and contributors to am-utils are listed in the AUTHORS file
distributed with am-utils.
Amq first appeared in 4.4BSD.
BSD March 16, 1991 BSD