AC(8) OpenBSD System Manager's Manual AC(8)
ac - connect time accounting
ac [-dp] [-t tty] [-w wtmp] [users ...]
If the file /var/log/wtmp exists, a record of individual login and logout
times are written to it by login(1) and init(8), respectively. ac exam-
ines these records and writes the accumulated connect time for all logins
to the standard output.
The options are as follows:
-d Display the connect times in 24 hour chunks.
-p Print individual users' totals.
-t tty Only do accounting logins on certain ttys. The tty specification
can start with `!' to indicate not this tty and end with `*' to
indicate all similarly named ttys. Multiple -t flags may be
Read connect time data from wtmp instead of the default file,
Display totals for the given individuals only.
If no arguments are given, ac displays the total connect time for all ac-
counts with login sessions recorded in wtmp.
The default wtmp file will increase without bound unless it is truncated.
It is normally truncated by the daily scripts run by cron(8), which re-
name and rotate the wtmp files, keeping a week's worth of data on hand.
No login or connect time accounting is performed if /var/log/wtmp does
$ ac -p -t "ttyd*" > modems
$ ac -p -t "!ttyd*" > other
allows times recorded in modems to be charged out at a different rate
The ac utility exits 0 on success or >0 if a fatal error occurred.
/var/log/wtmp connect time accounting file
/var/log/wtmp.[0-7] rotated files
login(1), utmp(5), init(8), sa(8)
An ac command appeared in Version 6 AT&T UNIX. This version of ac was
written for NetBSD 0.9A from the specification provided by various sys-
tems' manual pages.
OpenBSD 3.6 March 15, 1994 1