AC(8) BSD System Manager's Manual AC(8)
ac - display connect time accounting
ac [-d] [-p] [-w file] [users ...]
If the file /var/log/wtmp exists, a record of individual login and logout
times are written to it by init(8) and login(8) respectively. The pro-
gram ac examines these records and writes the accumulated connect time
for all logins to the standard output.
-d Display the connect times in 24 hour chunks.
-p Display individual user totals.
Read raw connect time data from file instead of the default file
Display totals for the given individuals only.
If no arguments are given, ac displays the total amount of login time for
all active accounts on the system.
The default wtmp file is an infinitely increasing file unless frequently
truncated. This is normally done by the daily daemon scripts scheduled
by cron(8) which rename and rotate the wtmp files before truncating them
(and keeping about a weeks worth on hand). No login times are collected
however, if the file does not exist.
/var/log/wtmp.[0-7] rotated files
init(8), sa(8), login(1), utmp(5).
A ac command appeared in Version 6 AT&T UNIX.
4th Berkeley Distribution April 19, 1994 1