TESTS(7) Miscellaneous Information Manual TESTS(7)
tests -- introduction to the NetBSD test suite
The NetBSD test suite provides a collection of automated tests for two
major purposes. On the one hand, the test suite aids developers in
catching bugs and regressions in the code when they performing
modifications to the source tree. On the other hand, the test suite
allows end users (and, in particular, system administrators) to verify
that fresh installations of the NetBSD operating system behave correctly
in their hardware platform and also to ensure that the system does not
suffer from regressions during regular system operation and maintenance.
The NetBSD tests are implemented using the Automated Testing Framework
(ATF), a third-party package shipped with NetBSD; see atf(7) for details.
The NetBSD test suite is distributed as a separate installation set,
named tests.tgz, and the test programs are all installed under the
This manual page describes how to execute the test suite and how to
configure some of its optional features.
When to run the tests?
Before diving into the details of how to run the test suite, here are
some scenarios in which you should be running them:
o After a fresh installation of NetBSD to ensure that the system
works correctly on your hardware platform.
o After an upgrade of NetBSD to a different version to ensure
that the new code works well on your hardware platform and that
the upgrade did not introduce regressions in your
o After performing changes to the source tree to catch any bugs
and/or regressions introduced by the modifications.
o Periodically, maybe from a cron(8) job, to ensure that any
changes to the system (such as the installation of third-party
packages or manual modifications to configuration files) do not
introduce unexpected failures.
Installing the tests
If you chose to install the tests.tgz distribution set while setting up
your NetBSD system, the tests are already available in /usr/tests.
Otherwise, install the set now by running:
# cd /
# tar xzpf /path/to/tests.tgz
Running the tests
Use the following commands to run the whole test suite:
$ cd /usr/tests
$ atf-run | atf-report
The above will go through all test programs in /usr/tests recursively,
execute them, and, at the very end, show a report of the results of the
test suite. These results include the count of tests that succeeded
(passed), the names of the tests that failed, and the count of the tests
that were not executed (skipped) because the system configuration did not
meet their requirements.
If you are interested in saving the whole output of the test suite
execution so that you can later investigate failures, use the following
$ cd /usr/tests
$ atf-run | tee ~/tests.log | atf-report
The above command will save the raw output of the test suite in
~/tests.log, which you can later inspect manually to look for failures.
Note that the file contains a copy of the `stdout' and `stderr' of each
test case, which becomes valuable during debugging.
It is also possible to restrict which tests to execute so that only a
small subsystem is tested; see atf-run(1) for details. Additionally, it
is also possible to run the test programs themselves by hand; see
atf-test-program(1) for more details, but be aware that you should only
be doing this if you are debugging failing tests.
Configuring the tests
Some test cases in the NetBSD test suite require the administrator to
manually set up some configuration properties before they can run.
Unless these properties are defined, the tests that require them will be
marked as skipped and thus they will not be really executed.
Each test suite is configured through a separate file that lives under
/etc/atf/ and that carries the name of the test suite. Henceforth, to
configure the properties that affect the execution of the NetBSD test
suite, you need to edit /etc/atf/NetBSD.conf. The suite-specific
configuration file implicitly depends on /etc/atf/common.conf, which
contains properties shared among all test suites. These files conform to
the configuration file format described in atf-formats(5).
The following configuration variables are available in the NetBSD test
fstype When set to a filesystem type, restrict tests programs
from the /usr/tests/fs/vfs/ tree to only run test
cases for the given type.
unprivileged-user This variable allows setting an unprivileged user
login name to be used by tests. Defaults to `_tests'.
What to do if something fails?
If there is any failure during the execution of the test suite, please
considering reporting it to the NetBSD developers so that the failure can
be analyzed and fixed. To do so, either send a message to the
appropriate mailing list or file a problem report. For more details
please refer to:
/etc/atf/NetBSD.conf Configuration file for the NetBSD test suite.
/etc/atf/common.conf Configuration file for all test suites.
/usr/tests/ Location of the test suites.
The tests manual page first appeared in NetBSD 6.0.
The ATF testing framework was first distributed with NetBSD 5.0 and the
collection of test programs in /usr/tests has been growing since then.
Julio Merino <jmmvATNetBSD.org>
NetBSD 6.1.5 August 5, 2011 NetBSD 6.1.5