STICKY(7) BSD Miscellaneous Information Manual STICKY(7)
sticky -- Description of the `sticky' (S_ISVTX) bit functionality
A special file mode, called the sticky bit (mode S_ISVTX), is used to
indicate special treatment for directories. See chmod(2) or the file
The use of mode S_ISVTX is reserved and can be set only by the super-
user. NetBSD does not currently treat plain files that have the sticky
bit set specially, but this behavior might change in the future.
A directory whose ``sticky bit'' is set becomes an append-only directory,
or, more accurately, a directory in which the deletion of files is
restricted. A file in a sticky directory may only be removed or renamed
by a user if the user has write permission for the directory and the user
is the owner of the file, the owner of the directory, or the super-user.
This feature is usefully applied to directories such as /tmp which must
be publicly writable but should deny users the license to arbitrarily
delete or rename each others' files.
Any user may create a sticky directory. See chmod(1) for details about
modifying file modes.
The sticky bit first appeared in V7, and this manual page appeared in
section 8. Its initial use was to mark sharable executables that were
frequently used so that they would stay in swap after the process exited.
Sharable executables were compiled in a special way so their text and
read-only data could be shared amongst processes. vi(1) and sh(1) were
such executables. This is where the term ``sticky'' comes from - the
program would stick around in swap, and it would not have to be fetched
again from the file system. Of course as long as there was a copy in the
swap area, the file was marked busy so it could not be overwritten. On
V7 this meant that the file could not be removed either, because busy
executables could not be removed, but this restriction was lifted in BSD
To replace such executables was a cumbersome process. One had first to
remove the sticky bit, then execute the binary so that the copy from swap
was flushed, overwrite the executable, and finally reset the sticky bit.
Later, on SunOS 4, the sticky bit got an additional meaning for files
that had the bit set and were not executable: read and write operations
from and to those files would go directly to the disk and bypass the buf-
fer cache. This was typically used on swap files for NFS clients on an
NFS server, so that swap I/O generated by the clients on the servers
would not evict useful data from the server's buffer cache.
Neither open(2) nor mkdir(2) will create a file with the sticky bit set.
BSD January 30, 2004 BSD