RELEASE(7) BSD Miscellaneous Information Manual RELEASE(7)
release -- layout of NetBSD releases and snapshots
This document describes the layout of NetBSD releases and snapshots.
This layout should be consistent between FTP servers and CD-ROMs, except
possibly the path that leads to the release hierarchy.
In this document, the following special words have these definitions:
<machine> The platform for which the release was built, correspond-
ing to the hw.machine sysctl variable, e.g. i386 or
<machine_arch> The architecture for which a particular installation set
was built, corresponding to the hw.machine_arch sysctl
variable, e.g. i386 or m68k.
<rel> The target release.
All README files are descriptions of the various files in directories
that have ``non-standard'' contents.
All BSDSUM files are historic BSD checksums for the various files in that
directory, in the format produced by the command: cksum -o 1 <<file>>.
All CKSUM files are POSIX checksums for the various files in that direc-
tory, in the format produced by the command: cksum <<file>>.
All MD5 files are MD5 digests for the various files in that directory, in
the format produced by the command: cksum -m <<file>>.
All SYSVSUM files are historic AT&T System V UNIX checksums for the vari-
ous files in that directory, in the format produced by the command: cksum
-o 2 <<file>>.
The MD5 digest is the safest checksum, followed by the POSIX checksum.
The other two checksums are provided only to ensure that the widest pos-
sible range of system can check the integrity of the release files.
Files that end in .tgz are gzipped tar archives. This is used in lieu of
.tar.gz because the software used to download the sets may incorrectly
auto-unpack files ending in .gz and to accommodate systems which only
support 3 character extensions to file names.
All tar archives are relative to the target's / directory, and do not
include the leading ``/''.
All compression of release files is to be performed with the command:
The root of the release hierarchy is .../NetBSD-<rel>/<machine>/.
Files which may be shared by all systems of the same <machine_arch> will
be located in .../NetBSD-<rel>/shared/<machine_arch>/ with symbolic links
pointing to these files from the <machine> subdirectory. Files which are
completely machine-independent will be located in
.../NetBSD-<rel>/shared/ALL/ with symbolic links pointing to these files
from the <machine> subdirectory.
Sources should be put into .../NetBSD-<rel>/source/ using the following
source/ Source codes of the operating system and patches for it.
patches/ This directory contains various patch files appropri-
ate for patch(1). Other patches may exist for fixing
Diff against the last release,
usually generated by cvs
rdiff. For patch releases,
diffs against the last release
are included. If the last
release was a patch release
itself, the diff is against
that patch release is
sets/ Sources for the various system sets, based on their
modules in the CVS server.
Split/ installation sets split with the
gnusrc.tgz Contains sources for all GPLed and pos-
sibly other programs that contains
restrictions in their licensing that
prevent others from using these programs
in closed-source environments.
pkgsrc.tgz Package-sources for third party software
ready to compile. See pkgsrc/README for
sharesrc.tgz Contains machine-independent data files
that can be shared across architec-
src.tgz The operating system's userland source
code, including all programs, tools,
syssrc.tgz Kernel sources for all architectures
plus sources of the tools needed to
build kernels (like config(8)).
xsrc.tgz Source code of the X Window System used
on all NetBSD architectures. Includes X
clients and servers.
The release in .../NetBSD-<rel>/<machine>/ follows the following layout:
SOURCE_DATE a file containing the date, in UTC, of the source code
from which the release or snapshot was built, in the
default format produced by the command: date -u
INSTALL.txt Installation notes, including complete descriptions of
files contained within the release hierarchy
INSTALL.more pretty version of this, suited for viewing with more(1)
INSTALL.html HTML version of this
INSTALL.ps PostScript version of this
binary/ system binaries
sets/ installation sets
Split/ installation sets split with the
split(1) command. Note: split
installation sets may not be
available for all platforms.
base.tgz The base binary distribution.
This set contains the base NetBSD
utilities that are necessary for
the system to run and be minimally
functional. It includes shared
libraries for those architectures
that support support them. This
set excludes all things listed in
the sets described below.
comp.tgz The compiler tools distribution.
This set contains the C and C++
compilers, assembler, linker,
other toolchain components, and
their manual pages. It also
includes the system include files
(/usr/include) , and the static
etc.tgz This set contains the system con-
figuration files that reside in
/etc and in several other places
throughout the file system hierar-
games.tgz This set includes the games and
their manual pages.
kern.tgz This set includes a generic ker-
man.tgz This set includes all of the man-
ual pages for the binaries and
other software contained in the
base set which are not included in
the other sets.
misc.tgz This set includes the system dic-
tionaries (which are rather
large), the typesettable document
set, and manual pages for other
architectures, which happen to be
installed from the source tree by
text.tgz This set includes the NetBSD text
processing tools, including
groff(1), all related programs,
and their manual pages.
xbase.tgz This set includes the base X11
distribution, including manual
pages and shared libraries for
those architectures that support
them, and excluding everything
contained in the other X11 sets.
xcomp.tgz This set includes the X11 include
files and static X11 libraries.
xcontrib.tgz This set includes binaries and
manual pages for programs built
from the X11 ``contrib'' sources.
xfont.tgz This set includes the X11 fonts.
xserver.tgz This set includes the X servers
and manual pages for <machine>.
Note: this set may not be
available on some platforms.
kernel/ suitably named, gzipped kernels
netbsd-GENERIC.gz A kernel built from the
GENERIC kernel configuration
file. This is meant as an
example only; different plat-
forms may have differently
installation/ installation helper items
cdrom/ CDROM images in ISO 9660 format, usually cre-
ated with ``make iso-image'' in src/etc after
a ``make release'' in both src and xsrc.
diskimage/ disk images, for those platforms that provide
floppy/ floppy images, for those platforms that pro-
miniroot/ miniroot images, for those platforms that pro-
misc/ miscellaneous installation helper utilities,
including boot selectors, floppy writing soft-
ware, other software that runs under foreign
operating systems, etc.
netboot/ network boot programs
tapeimage/ tape images, for those platforms that provide
cksum(1), date(1), gzip(1), split(1), tar(1)
The release manual page first appeared in NetBSD 1.3.
BSD October 6, 2000 BSD