diag0(7) Series 800 Only diag0(7)
diag0 - diagnostic interface to HP-PB I/O subsystem
diag0 is a diagnostic pseudo-driver, which provides HP support tools
with access to the HP-PB I/O subsystem. This driver is used by
hardware monitors and tools within the Support Tools Manager (STM), to
interact with peripherals connected to the system via HP-PB. The I/O
drivers also send diagnostic events to diag0 for diagnostic logging by
the Support Tools Manager.
Without diag0, information that could help prevent a peripheral
failure will be lost. In addition, if a failure occurs, HP will not
have the tools or data to diagnose the cause of the problem in a
timely manner. This may cause increased downtime and possible future
diag0 was developed by HP.
/dev/diag directory containing diagnostic device files
stm(1M) from the Support Tools Manager
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000