USERMGMT.CONF(5) BSD File Formats Manual USERMGMT.CONF(5)
usermgmt.conf -- user management tools configuration file
The usermgmt.conf file defines the default values used by the user man-
agement tools, user(8).
Options in this file can be set by manually editing /etc/usermgmt.conf or
using the -D option to useradd(8).
base_dir Sets the base directory name, in which new users' home direc-
tories are created when using the -m option to useradd(8).
class Sets the default login class for new users. See login.conf(5)
for more information on user login classes.
expire Sets the default time at which the new accounts expire. Both
the expire and inactive fields should be entered in the form
``month day year'', where month is the month name (the first
three characters are sufficient), day is the day of the month,
and year is the year. Time in seconds since the Epoch (UTC)
is also valid. A value of 0 can be used to disable this fea-
group Sets the default primary group for new users. If this is
'=uid', then a UID and GID will be picked which are both
unique and the same, and a line added to /etc/group to
describe the new group. It has the format:
group gid | name | =uid
inactive Sets the default time at which the passwords of new accounts
expire. A value of 0 can be used to disable this feature.
Also see the expire field.
password Specifies an already-encrypted default password.
preserve If this value is one of 'true', 'yes', or a non-zero number,
then the user login information will be preserved when remov-
ing a user with userdel(8).
range Specifies the UID boundaries for new users. If unspecified,
the default is ``1000..60000''. It has the format:
shell Sets the default login shell for new users.
skel_dir Sets the default skeleton directory in which to find files
with which to populate the new user's home directory.
login.conf(5), passwd(5), user(8), useradd(8), userdel(8), usermod(8)
Other implementations of the user(8) utilities use the inactive-time
parameter to refer to the maximum number of days allowed between logins
(this is used to lock "stale" accounts that have not been used for a
period of time). However, on OpenBSD systems this parameter refers
instead to the password change time. This is due to differences in the
passwd(5) database compared to other operating systems.
The usermgmt.conf configuration file first appeared in OpenBSD 2.7.
BSD March 23, 2017 BSD