sticky(5) Standards, Environments, and Macros sticky(5)
sticky - mark files for special treatment
The sticky bit (file mode bit 01000, see chmod(2)) is used to indicate
special treatment of certain files and directories. A directory for
which the sticky bit is set restricts deletion of files it contains. A
file in a sticky directory can only be removed or renamed by a user who
has write permission on the directory, and either owns the file, owns
the directory, has write permission on the file, or is a privileged
user. Setting the sticky bit is useful for directories such as /tmp,
which must be publicly writable but should deny users permission to
arbitrarily delete or rename the files of others.
If the sticky bit is set on a regular file and no execute bits are set,
the system's page cache will not be used to hold the file's data. This
bit is normally set on swap files of diskless clients so that accesses
to these files do not flush more valuable data from the system's cache.
Moreover, by default such files are treated as swap files, whose inode
modification times may not necessarily be correctly recorded on perma-
Any user may create a sticky directory. See chmod for details about
modifying file modes.
chmod(1), chmod(2), chown(2), mkdir(2), rename(2), unlink(2)
The mkdir(2) function will not create a directory with the sticky bit
SunOS 5.10 1 Aug 2002 sticky(5)