smf_restarter(5) Standards, Environments, and Macros smf_restarter(5)
smf_restarter - service management facility conventions for restarters
All service instances in the service management facility must be man-
aged by a restarter. This manual page describes configuration, func-
tionality, and reporting characteristics that are common to all
restarters in the framework. Characteristics specific to a particular
restarter are described in the restarter's manpage.
For each managed service, a restarter relies on retrieving properties
on the service instance to determine configuration. The restarter man-
ages a set of property groups to communicate the current disposition of
a service with display tools such as svcs(1).
The common restarter configuration for all services is captured in the
general property group. This group includes the following required and
optional property settings.
enabled This is a required property. If set, the
restarter of an instance attempts to maintain
availability of the service.
restarter This is an optional property that allows the
specification of an alternate restarter to man-
age the service instance. If the restarter
property is empty or absent, the restarter
defaults to svc.startd(1M).
single_instance This is an optional property. When set, only
one instance of the service is allowed to tran-
sition to an online or degraded status at any
transient_process This is an optional property. When specified,
the service does not contain objects that run
All restarters report status using the restarter property group, which
includes the following properties:
next_state The current state and next state, if currently
in transition, for instances stored in these
properties. See smf(5) for a description of the
auxiliary_state An astring with no spaces that contains a pre-
cise term to describe the full restarter-spe-
cific state in combination with the restarter
state property. The auxiliary state may not
always be set and is always cleared during
transition out of any state. Each restarter
must define the precise list of auxiliary
states it will use.
state_timestamp The time when the current state was reached.
contract The primary process contract ID, if any, under
which the service instance is executing.
svcs(1), svc.startd(1M), service_bundle(4), smf(5), smf_method(5)
SunOS 5.10 08 Mar 2004 smf_restarter(5)