SHELLS(5) BSD File Formats Manual SHELLS(5)
shells -- shell database
The shells file contains a list of valid shells available on the system.
A shell is a command line interpreter that reads user input and executes
commands. For each shell a single line should be present, consisting of
the shell's path, relative to root.
A hash mark ('#') indicates the beginning of a comment; subsequent char-
acters up to the end of the line are not interpreted by the routines
which search the file. Blank lines are also ignored.
The chpass(1) program will not let regular users change their default
shell to one not listed in the shells file. The ftpd(8) daemon denies
access to users who are not using one of the listed shells.
chpass(1), login(1), getusershell(3), nologin(8)
The shells file format appeared in 4.3BSD-Tahoe.
BSD May 23, 2017 BSD