SERVICES(5) BSD File Formats Manual SERVICES(5)
services -- service name database
The services file contains information regarding the known services
available in the DARPA Internet. For each service, a single line should
be present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The
port number and protocol name are considered a single item; a slash ('/')
is used to separate the port and protocol (e.g., ``512/tcp'').
A hash mark ('#') indicates the beginning of a comment; subsequent char-
acters up to the end of the line are not interpreted by the routines
which search the file.
Service names may contain any printable character other than a field
delimiter, newline, or comment character.
The services file format appeared in 4.2BSD.
A name server should be used instead of a static file. Lines in
/etc/services are limited to BUFSIZ characters (currently 1024). Longer
lines will be ignored.
BSD May 31, 2007 BSD