ROUTE.CONF(5) BSD File Formats Manual ROUTE.CONF(5)
route.conf -- static routes config file
The route.conf file is read by the staticroute rc.d script during system
start-up and shutdown, and is intended for adding and removing static
Lines starting with a hash ('#') are comments and ignored. Lines start-
ing with a plus sign ('+') are run during start-up, while lines starting
with a minus sign ('-') are run during system shutdown. All other lines
are passed to route(8). During start-up, they are passed behind a
``route add -'' command and during shutdown behind a ``route delete -''
/etc/route.conf The route.conf file resides in /etc.
rc.d(8) script that parses route.conf.
In this example, if the staticroute script is enabled in rc.conf(5), IP
forwarding is turned on during start-up, and a static route added for
192.168.2.0. During system shutdown, the route is removed and IP for-
warding turned off.
# Turn on/off IP forwarding.
+sysctl -w net.inet.ip.forwarding=1
-sysctl -w net.inet.ip.forwarding=0
net 192.168.2.0 -netmask 255.255.255.0 192.168.150.2
rc.conf(5), rc(8), route(8)
BSD June 24, 2004 BSD