RESOLV.CONF(5) OpenBSD Programmer's Manual RESOLV.CONF(5)
resolv.conf - resolver configuration file
The resolv.conf file specifies how the resolver(3) routines in the C li-
brary (which provide access to the Internet Domain Name System) should
operate. The resolver configuration file contains information that is
read by the resolver routines the first time they are invoked by a pro-
cess. The file is designed to be human readable and contains a list of
keywords with values that provide various types of resolver information.
A hash mark `#' or semicolon `;' indicates the beginning of a comment;
subsequent characters up to the end of the line are not interpreted by
the routines that read the file.
On a normally configured system this file should not be necessary. The
only name server to be queried will be on the local machine, the domain
name is determined from the host name, and the domain search path is con-
structed from the domain name.
The different configuration options are:
nameserver IPv4 address (in dot notation) or IPv6 address (in hex-and-
colon notation) of a name server that the resolver should
query. Scoped IPv6 address notation is accepted as well (see
inet6(4) for details). Up to MAXNS (currently 3) name
servers may be listed, one per keyword. If there are multi-
ple servers, the resolver library queries them in the order
listed. If no nameserver entries are present, the default is
to use the name server on the local machine. (The algorithm
used is to try a name server, and if the query times out, try
the next, until out of name servers, then repeat trying all
name servers until a maximum number of retries are per-
domain Local domain name. Most queries for names within this domain
can use short names relative to the local domain. If no
domain entry is present, the domain is determined from the
local host name returned by gethostname(3); the domain part
is taken to be everything after the first ``.''. Finally, if
the host name does not contain a domain part, the root domain
lookup This keyword is used by the library routines gethostbyname(3)
and gethostbyaddr(3). It specifies which databases should be
searched, and the order to do so. The legal space-separated
bind Use the Domain Name server by querying named(8).
file Search for entries in /etc/hosts.
yp Talk to the YP system if ypbind(8) is running.
If the lookup keyword is not used in the system's resolv.conf
file then the assumed order is bind file. Furthermore, if
the system's resolv.conf file does not exist, then the only
database used is file.
search Search list for hostname lookup. The search list is normally
determined from the local domain name; by default, it begins
with the local domain name, then successive parent domains
that have at least two components in their names. This may
be changed by listing the desired domain search path follow-
ing the search keyword with spaces or tabs separating the
names. Most resolver queries will be attempted using each
component of the search path in turn until a match is found.
Note that this process may be slow and will generate a lot of
network traffic if the servers for the listed domains are not
local, and that queries will time out if no server is avail-
able for one of the domains.
The search list is currently limited to six domains with a
total of 1024 characters.
sortlist Allows addresses returned by gethostbyname(3) to be sorted.
A sortlist is specified by IP address netmask pairs. The
netmask is optional and defaults to the natural netmask of
the net. The IP address and optional network pairs are sepa-
rated by slashes. Up to 10 pairs may be specified, e.g.:
sortlist 22.214.171.124/255.255.240.0 126.96.36.199
options Allows certain internal resolver variables to be modified.
The syntax is:
options option ...
where option is one of the following:
debug Sets RES_DEBUG in _res.options.
edns0 attach OPT pseudo-RR for ENDS0 extension specified
in RFC 2671, to inform DNS server of our receive
buffer size. The option will allow DNS servers to
take advantage of non-default receive buffer size,
and to send larger replies. DNS query packets
with EDNS0 extension are not compatible with non-
EDNS0 DNS servers. The option must be used only
when all the DNS servers listed in nameserver
lines are able to handle EDNS0 extension.
inet6 Enables support for IPv6-only applications, by
setting RES_USE_INET6 in _res.options (see
resolver(3)). Use of this option is discouraged,
and meaningless on OpenBSD.
insecure1 Do not require IP source address on the reply
packet to be equal to the server's address.
insecure2 Do not check if the query section of the reply
packet is equal to that of the query packet. For
testing purposes only.
ndots:n Sets a threshold for the number of dots which must
appear in a name given to res_query (see
resolver(3)) before an initial absolute query will
be made. The default for n is 1, meaning that if
there are any dots in a name, the name will be
tried first as an absolute name before any search
list elements are appended to it.
The domain and search keywords are mutually exclusive. If more than one
instance of these keywords is present, the last instance will override.
The search keyword of a system's resolv.conf file can be overridden on a
per-process basis by setting the environment variable LOCALDOMAIN to a
space-separated list of search domains.
The options keyword of a system's resolv.conf file can be amended on a
per-process basis by setting the environment variable RES_OPTIONS to a
space-separated list of resolver options as explained above.
The keyword and value must appear on a single line, and the keyword
(e.g., nameserver) must start the line. The value follows the keyword,
separated by whitespace.
gethostbyname(3), resolver(3), hosts(5), hostname(7), named(8)
Name Server Operations Guide for BIND.
The resolv.conf file format appeared in 4.3BSD.
Due to resolver internal issues, getaddrinfo(3) may not behave as lookup
suggests. Consequently, userland programs that use getaddrinfo(3) may
behave differently from what lookup says.
OpenBSD 3.6 May 10, 1991 3