REMOTE(5) BSD File Formats Manual REMOTE(5)
remote -- remote host description file
The systems known by tip(1) and their attributes are stored in an ASCII
file which is structured somewhat like the termcap(5) file. Each line in
the file provides a description for a single remote host. Fields are
separated by a colon (':'). Lines ending with a ``\'' character immedi-
ately followed by a newline are continued on the next line.
The first entry is the name(s) of the host system. If there is more than
one name for a system, the names are separated by vertical bars ('|').
After the name of the system comes the fields of the description. A
field name followed by an equal sign ('=') indicates a string value fol-
lows. A field name followed by a pound sign ('#') indicates a following
Entries named ``tip*'' are used as default entries by tip(1) as follows.
When tip(1) is invoked with only a baud rate, it looks for an entry of
the form ``tip<baud rate>''. E.g. tip -300 will cause tip(1) to look for
the system tip300.
Capabilities are either strings (str), numbers (num), or boolean flags
(bool). A string capability is specified by capability=value; for exam-
ple, ``dv=/dev/harris''. A numeric capability is specified by
capability#value; for example, ``xa#99''. A boolean capability is speci-
fied by simply listing the capability.
be (bool) Initialize the tip(1) variable ``beautify'' to on, so that
non-printable characters will be discarded when scripting.
br (num) The baud rate used in establishing a connection to the
remote host. This is a decimal number. The default baud rate is
cm (str) An initial connection message to be sent to the remote
host. For example, if a host is reached through port selector,
this might be set to the appropriate sequence required to switch
to the host.
dc (bool) This host is directly connected, and tip(1) should not
expect carrier detect to be high, nor should it exit if carrier
di (str) Disconnect message sent to the host when a disconnect is
requested by the user.
dv (str) UNIX device(s) to open to establish a connection. If this
file refers to a terminal line, tip(1) attempts to perform an
exclusive open on the device to ensure only one user at a time
has access to the port.
ec (bool) Initialize the tip(1) variable ``echocheck'' to on, so
that tip(1) will synchronize with the remote host during file
transfer by waiting for the last character transmitted to echo.
el (str) Characters marking an end-of-line. The default is NULL.
``~'' escapes are only recognized by tip(1) after one of the
characters in el, or after a carriage-return.
es (str) The escape character for tip(1). The default is ``~''.
et (num) Number of seconds to wait for an echo response when
``echocheck'' mode is on. The default value is 10 seconds.
ex (str) Set of non-printable characters not to be discarded when
scripting with beautification turned on. The default value is
fo (str) Character used to force literal data transmission. The
default value is '\020' (^P).
fs (str) Frame size for transfers. The default frame size is equal
hd (bool) The host uses half-duplex communication, local echo should
hf (bool) Initialize the tip(1) variable ``hardwareflow'' to on, so
that hardware flow control (CRTSCTS) will be used for the connec-
tion with the remote host.
ie (str) Input end-of-file marks. The default is NULL.
ld (num) The line discipline to use for the remote tty. The default
is to use the termios(4) line discipline.
nb (bool) Initialize the tip(1) variable ``beautify'' to off, so
that non-printable characters will not be discarded when script-
nt (bool) Initialize the tip(1) variable ``tandem'' to off, so that
XON/XOFF flow control will not be used to throttle data from the
nv (bool) Initialize the tip(1) variable ``verbose'' to off, so that
verbose mode will be turned off.
oe (str) Output end-of-file string. The default is NULL. When
tip(1) is transferring a file, this string is sent at end-of-
pa (str) The type of parity to use when sending data to the host.
This may be one of ``even'', ``odd'', ``none'', ``zero'' (always
set bit 8 to zero), or ``one'' (always set bit 8 to one). The
default is no parity.
pr (str) Character that indicates end-of-line on the remote host.
The default value is '\n'.
ra (bool) Initialize the tip(1) variable ``raise'' to on, so that
lowercase letters are mapped to uppercase before sending them to
the remote host.
rc (str) Character that toggles case-mapping mode. The default
value is NULL.
re (str) The file in which to record session scripts. The default
value is tip.record.
rw (str) Initialize the tip(1) variable ``rawftp'' to on, so that
all characters will be sent as is during file transfers.
sc (bool) Initialize the tip(1) variable ``script'' to on, so that
everything transmitted by the remote host will be recorded.
ta (bool) Initialize the tip(1) variable ``tandem'' to on, so that
XON/XOFF flow control will be used to throttle data from the
tb (bool) Initialize the tip(1) variable ``tabexpand'' to on, so
that each tab will be expanded to 8 spaces during file transfers.
tc (str) Indicates that the list of capabilities is continued in the
named description. This is used primarily to share common capa-
vb (bool) Initialize the tip(1) variable ``verbose'' to on, so that
verbose mode will be turned on.
/etc/remote Global database.
The remote file format appeared in 4.2BSD.
BSD April 25, 2017 BSD