RC.CONF(5) BSD File Formats Manual RC.CONF(5)
rc.conf -- system startup configuration file
The rc.conf file specifies which services are enabled during system
startup by the startup scripts invoked by /etc/rc (see rc(8)), and the
shutdown scripts invoked by /etc/rc.shutdown. The rc.conf file is a
shell script that is sourced by rc(8), meaning that rc.conf must contain
valid shell commands.
Listed below are the standard rc.conf variables that may be set, the val-
ues to which each may be set, a brief description of what each variable
does, and a reference to relevant manual pages. Third party packages may
test for additional variables.
Most variables are one of two types: enabling variables or flags vari-
ables. Enabling variables, such as inetd, are generally named after the
program or the system they enable, and are set to 'YES' or 'NO'. Flags
variables, such as inetd_flags have the same name with "_flags" appended,
and determine what arguments are passed to the program if it is enabled.
If a variable that rc(8) expects to be set is not set, or the value is
not one of the allowed values, a warning will be printed.
By default, rc.conf reads /etc/defaults/rc.conf (if it is readable) to
obtain default values for various variables, and the end-user may over-
ride these by appending appropriate entries to the end of rc.conf.
rc.d(8) scripts that use load_rc_config from rc.subr(8) also support
sourcing an optional end-user provided per-script override file
/etc/rc.conf.d/service, (where service is the contents of the name vari-
able in the rc.d(8) script). This may contain variable overrides,
including allowing the end-user to override various run_rc_command
rc.d(8) control variables, and thus changing the operation of the script
without requiring editing of the script.
do_rcshutdown 'YES' or 'NO'. If set to 'NO', shutdown(8) will not run
A string. Extra arguments to the rcorder(8) run by
A number. If non-blank, use this as the number of sec-
onds to run a watchdog timer for which will terminate
/etc/rc.shutdown if the timer expires before the shutdown
rc_configured 'YES' or 'NO'. If not set to 'YES' then the system will
drop into single-user mode during boot.
If set to a non-empty string, each script in /etc/rc.d
will be executed in the current shell rather than a sub
shell. This may be faster on slow machines that have an
expensive fork(2) operation.
Note: Use this at your own risk! A rogue command or
script may inadvertently prevent boot to multi-
A string. Extra arguments to the rcorder(8) run by
Basic network configuration
defaultroute A string. Default network route. If empty or not set,
then the contents of /etc/mygate (if it exists) are used.
domainname A string. NIS (YP) domain of host. If empty or not set,
then the contents of /etc/defaultdomain (if it exists)
A space separated list of interface names. These inter-
faces will be configured down when going from multiuser
to singleuser mode or on system shutdown.
This is important for some stateful interfaces, for exam-
ple PPP over ISDN connections that cost money by connec-
tion time or PPPoE interfaces which have no direct means
of noticing ``disconnect'' events.
All active pppoe(4) and ippp(4) interfaces will be auto-
matically added to this list.
hostname A string. Name of host. If empty or not set, then the
contents of /etc/myname (if it exists) are used.
Boottime file-system and swap configuration
A string. File systems mounted very early in the system
boot before networking services are available. Usually
/var is part of this, because it is needed by services
such as dhclient(8) which may be required to get the net-
A string. File systems such as /usr that may require
network services to be available to mount, that must be
available early in the system boot for general services
fsck_flags A string. A file system is checked with fsck(8) during
boot before mounting it. This option may be used to
override the default command-line options passed to the
When set to -y, fsck(8) assumes yes as the answer to all
operator questions during file system checks. This might
be important with hosts where the administrator does not
have access to the console and an unsuccessful shutdown
must not make the host unbootable even if the file system
checks would fail in preen mode.
no_swap 'YES' or 'NO'. Set the no_swap variable to 'YES' if you
have configured your system with no swap on purpose. If
not set to 'YES', and no swap devices are configured, the
system will warn you.
swapoff 'YES' or 'NO'. Remove block-type swap devices at shut-
down time. Useful if swapping onto RAIDframe devices.
One-time actions to perform or programs to run on boot-up
accounting 'YES' or 'NO'. Enables process accounting with
accton(8). Requires /var/account/acct to exist.
clear_tmp 'YES' or 'NO'. Clear /tmp after reboot.
dmesg 'YES' or 'NO'. Create /var/run/dmesg.boot from the out-
put of dmesg(8). Passes dmesg_flags.
lkm 'YES' or 'NO'. Runs /etc/rc.lkm.
mixerctl 'YES' or 'NO'. Read mixerctl.conf(5) for how to set
mixer values. List in mixerctl_mixers the devices whose
settings are to be saved at shutdown and restored at
newsyslog 'YES' or 'NO'. Run newsyslog to trim logfiles before
syslogd starts. Intended for laptop users. Passes
savecore 'YES' or 'NO'. Runs the savecore(8) utility. Passes
savecore_flags. The directory where crash dumps are
stored is specified by savecore_dir. The default setting
tpctl 'YES' or 'NO'. Run tpctl(8) to calibrate touch panel
device. Passes tpctl_flags.
update_motd 'YES' or 'NO'. Updates the NetBSD version string in the
/etc/motd file to reflect the version of the running ker-
nel. See motd(5).
veriexec 'YES' or 'NO'. Load verified exec fingerprints during
startup. Read veriexecctl(8) for more information.
virecover 'YES' or 'NO'. Send notification mail to users if any
recoverable files exist in /var/tmp/vi.recover. See -r
option in vi(1) for details.
System security setting
securelevel A number. The system securelevel is set to the specified
value early in the boot process, before any external
logins, or other programs that run users job, are
started. If set to nothing, the default action is taken,
as described in init(8), which contains definitive infor-
mation about the system securelevel. Note that setting
securelevel to 0 in rc.conf will actually result in the
system booting with securelevel set to 1, as init(8) will
raise the level when rc(8) completes.
altqd 'YES' or 'NO'. ALTQ configuration/monitoring daemon.
auto_ifconfig 'YES' or 'NO'. Sets the net_interfaces variable (see
below) to the output of ifconfig(8) with the ``-l'' flag
and suppresses warnings about interfaces in this list
that do not have an ifconfig file or variable.
dhclient 'YES' or 'NO'. Set to 'YES' to configure some or all
network interfaces using the DHCP client. If you set
dhclient to 'YES', you must either have /var in
critical_filesystems_local, as part of /, or direct the
DHCP client to store the leases file on the root file
system by modifying the dhclient_flags variable. You
must not provide ifconfig information or ifaliases infor-
mation for any interface that is to be configured using
the DHCP client. Interface aliases can be set up in the
DHCP client configuration file if needed - see
dhclient.conf(5) for details.
Passes dhclient_flags to the DHCP client. See
dhclient(8) for complete documentation. If you wish to
configure all broadcast network interfaces using the DHCP
client, you can leave this blank. To configure only spe-
cific interfaces, name the interfaces to be configured on
the command line.
If you must run the DHCP client before mounting critical
file systems, then you should specify an alternate loca-
tion for the DHCP client's lease file in the
dhclient_flags variable - for example, "-lf
flushroutes 'YES' or 'NO'. Flushes the route table on networking
startup. Useful when coming up to multiuser mode after
going down to single-user mode.
ifaliases_* A string. List of 'address netmask' pairs to configure
additional network addresses for the given configured
interface ``*'' (e.g. ifaliases_le0). If netmask is
``-'', then use the default netmask for the interface.
ifaliases_* covers limited cases only and considered
unrecommended. We recommend using /etc/ifconfig.xxN with
multiple lines instead.
ifwatchd 'YES' or 'NO'. Monitor dynamic interfaces and perform
actions upon address changes. Passes ifwatchd_flags.
ip6mode A string. An IPv6 node can be a router (nodes that
forward packet for others) or a host (nodes that do not
forward). A host can be autoconfigured based on the
information advertised by adjacent IPv6 routers. By set-
ting ip6mode to ``router'', ``host'', or ``autohost'',
you can configure your node as a router, a non-autocon-
figured host, or an autoconfigured host. Invalid values
will be ignored, and the node will be configured as a
non-autoconfigured host. You may want to check rtsol and
rtsold as well, if you set the variable to ``autohost''.
ip6sitelocal 'YES' or 'NO'. If you intend to use IPv6 site-local
addresses in your site, set it to 'YES'. Otherwise,
reject routes will get installed on boot to avoid miscon-
figuration relating to site-local addresses.
ipfilter 'YES' or 'NO'. Runs ipf(8) to load in packet filter
specifications from /etc/ipf.conf at network boot time,
before any interfaces are configured. See ipf.conf(5).
ipfs 'YES' or 'NO'. Runs ipfs(8) to save and restore informa-
tion for ipnat and ipfilter state tables. The informa-
tion is stored in /var/db/ipf/ipstate.ipf and
/var/db/ipf/ipnat.ipf. Passes ipfs_flags.
ipmon 'YES' or 'NO'. Runs ipmon(8) to read ipf(8) packet log
information and log it to a file or the system log.
ipmon_flags A string. Specifies arguments to supply to ipmon(8).
Defaults to ``-ns''. A typical example would be ``-nD
/var/log/ipflog'' to have ipmon(8) log directly to a file
bypassing syslogd(8). If the ``-D'' argument is used,
remember to modify /etc/newsyslog.conf accordingly; for
/var/log/ipflog 640 10 100 * Z /var/run/ipmon.pid
ipnat 'YES' or 'NO'. Runs ipnat(8) to load in the IP network
address translation (NAT) rules from /etc/ipnat.conf at
network boot time, before any interfaces are configured.
ipsec 'YES' or 'NO'. Runs setkey(8) to load in IPsec manual
keys and policies from /etc/ipsec.conf at network boot
time, before any interfaces are configured.
net_interfaces A string. The list of network interfaces to be config-
ured at boot time. For each interface "xxN", the system
first looks for ifconfig parameters in /etc/ifconfig.xxN
and then in the variable ifconfig_xxN. The contents of
the file or the variable are handed to ifconfig after the
interface name. If auto_ifconfig is set to "NO" and nei-
ther the file nor the variable is found, a warning is
printed. Refer to ifconfig.if(5) for more details on
ntpdate 'YES' or 'NO'. Runs ntpdate(8) to set the system time
from one of the hosts in ntpdate_hosts. If ntpdate_hosts
is empty, it will attempt to find a list of hosts in
/etc/ntp.conf. Passes ntpdate_flags.
ppp_peers A string. If ppp_peers is not empty, then /etc/rc.d/ppp
will check each word in ppp_peers for a corresponding ppp
configuration file in /etc/ppp/peers and will call
pppd(8) with the ``call peer'' option.
racoon 'YES' or 'NO'. Runs racoon(8), the IKE (ISAKMP/Oakley)
key management daemon.
rtsol 'YES' or 'NO'. Run rtsol(8), router solicitation command
for IPv6 hosts. On nomadic hosts like notebook comput-
ers, you may want to enable rtsold as well. Passes
rtsol_flags. This is only for autoconfigured IPv6 hosts,
so set ip6mode to ``autohost'' if you use it.
Daemons required by other daemons
inetd 'YES' or 'NO'. Runs the inetd(8) daemon to start network
server processes (as listed in /etc/inetd.conf) as neces-
sary. Passes inetd_flags. The ``-l'' flag turns on lib-
wrap connection logging.
rpcbind 'YES' or 'NO'. The rpcbind(8) daemon is required for any
rpc(3) services. These include NFS, NIS, bootparamd(8),
rstatd(8), rusersd(8), and rwalld(8). Passes
Commonly used daemons
cron 'YES' or 'NO'. Run cron(8).
lpd 'YES' or 'NO'. Runs lpd(8) and passes lpd_flags. The
``-l'' flag will turn on extra logging.
named 'YES' or 'NO'. Runs named(8) and passes named_flags.
A string. If non-blank and named is 'YES', run named(8)
as the unprivileged user and group 'named', chroot(2)ed
to named_chrootdir. named_chrootdir/var/run/log will be
added to the list of log sockets that syslogd(8) listens
ntpd 'YES' or 'NO'. Runs ntpd(8) and passes ntpd_flags.
ntpd_chrootdir A string. If non-blank and ntpd is 'YES', run ntpd(8) as
the unprivileged user and group 'ntpd', chroot(2)ed to
ntpd_chrootdir. ntpd_chrootdir/var/run/log will be added
to the list of log sockets that syslogd(8) listens to.
This option requires that the kernel has
compiled in, and that /dev/clockctl is present.
postfix 'YES' or 'NO'. Starts postfix(1) mail system.
sendmail 'YES' or 'NO'. Runs sendmail(8) and passes
sendmail_flags. The default setting for this calls on a
function to determine if sendmail is actually needed,
which means the rc.d(8) script that starts sendmail will
check to see if sendmail(8) needs to run in order to
facilitate local mail delivery. See
/etc/defaults/rc.conf, /etc/mailer.conf, and
mailer.conf(5) for more details.
'YES' or 'NO'. Asserts that sendmail is being used as a
setuid root binary and adjusts some precmd checks accord-
ingly. If this is set to 'YES', you can remove the sub-
mit.cf file, and then turn off the smmsp process. Note
that setting this to 'YES' does not change or remove any-
thing; you must still change the mode of the sendmail
binary and remove the submit.cf file manually.
smmsp 'YES' or 'NO'. Runs sendmail(8) as a client queue runner
and passes smmsp_flags. Note that the smmsp process is
not a full-featured SMTP daemon. Its main purpose is to
flush locally collected mail from the queue, but it can
also be used as a non-privileged ``nullclient'' that for-
wards to a more functional SMTP gateway.
sshd 'YES' or 'NO'. Runs sshd(8) and passes sshd_flags.
syslogd 'YES' or 'NO'. Runs syslogd(8) and passes syslogd_flags.
timed 'YES' or 'NO'. Runs timed(8) and passes timed_flags.
The ``-M'' option allows timed(8) to be a master time
source as well as a slave. If you are also running
ntpd(8), only one machine running both should have the
``-M'' flag given to timed(8).
mrouted 'YES' or 'NO'. Runs mrouted(8), the DVMRP multicast
routing protocol daemon. Passes mrouted_flags.
route6d 'YES' or 'NO'. Runs route6d(8), the RIPng routing proto-
col daemon for IPv6. Passes route6d_flags.
routed 'YES' or 'NO'. Runs routed(8), the RIP routing protocol
daemon. Passes routed_flags.
rtsold 'YES' or 'NO'. Runs rtsold(8), the IPv6 router solicita-
tion daemon. rtsold(8) periodically transmits router
solicitation packets to find IPv6 routers on the network.
This configuration is mainly for nomadic hosts like note-
book computers. Stationary hosts should work fine with
just rtsol. Passes rtsold_flags. This is only for auto-
configured IPv6 hosts, so set ip6mode to ``autohost'' if
you use it.
Daemons used to boot other hosts over a network
bootparamd 'YES' or 'NO'. Runs bootparamd(8), the boot parameter
server, with bootparamd_flags as options. Used to boot
NetBSD and SunOS 4.x systems.
dhcpd 'YES' or 'NO'. Runs dhcpd(8), the Dynamic Host Configu-
ration Protocol (DHCP) daemon, for assigning IP addresses
to hosts and passing boot information. Passes
dhcrelay 'YES' or 'NO'. Runs dhcrelay(8). Passes dhcrelay_flags.
mopd 'YES' or 'NO'. Runs mopd(8), the DEC MOP protocol dae-
mon; used for booting VAX and other DEC machines. Passes
ndbootd 'YES' or 'NO'. Runs ndbootd(8), the Sun Network Disk
(ND) Protocol server. Passes ndbootd_flags.
rarpd 'YES' or 'NO'. Runs rarpd(8), the reverse ARP daemon,
often used to boot NetBSD and Sun workstations. Passes
rbootd 'YES' or 'NO'. Runs rbootd(8), the HP boot protocol dae-
mon; used for booting HP workstations. Passes
rtadvd 'YES' or 'NO'. Runs rtadvd(8), the IPv6 router adver-
tisement daemon, which is used to advertise information
about the subnet to IPv6 end hosts. Passes rtadvd_flags.
This is only for IPv6 routers, so set ip6mode to
``router'' if you use it.
X Window System daemons
xdm 'YES' or 'NO'. Runs the xdm(1) X display manager. These
X daemons are available only with the optional X distri-
bution of NetBSD.
xfs 'YES' or 'NO'. Runs the xfs(1) X11 font server, which
supplies local X font files to X terminals.
NIS (YP) daemons
ypbind 'YES' or 'NO'. Runs ypbind(8), which lets NIS (YP)
clients use information from a NIS server. Passes
yppasswdd 'YES' or 'NO'. Runs yppasswdd(8), which allows remote
NIS users to update password on master server. Passes
ypserv 'YES' or 'NO'. Runs ypserv(8), the NIS (YP) server for
distributing information from certain files in /etc.
Passes ypserv_flags. The ``-d'' flag causes it to use
DNS for lookups in /etc/hosts that fail.
NFS daemons and parameters
amd 'YES' or 'NO'. Runs amd(8), the automounter daemon,
which automatically mounts NFS file systems whenever a
file or directory within that file system is accessed.
amd_dir A string. The amd(8) mount directory. Used only if amd
is set to 'YES'.
lockd 'YES' or 'NO'. Runs rpc.lockd(8) if nfs_server and/or
nfs_client are set to 'YES'. Passes lockd_flags.
mountd 'YES' or 'NO'. Runs mountd(8) and passes mountd_flags.
nfs_client 'YES' or 'NO'. The number of local NFS asynchronous I/O
server is now controlled via sysctl(8).
nfs_server 'YES' or 'NO'. Sets up a host to be a NFS server by run-
ning nfsd(8) and passing nfsd_flags.
statd 'YES' or 'NO'. Runs rpc.statd(8), a status monitoring
daemon used when rpc.lockd(8) is running, if nfs_server
and/or nfs_client are set to 'YES'. Passes statd_flags.
isdnd 'YES' or 'NO'. Runs isdnd(8), the isdn4bsd ISDN connec-
tion management daemon. Passes isdnd_flags.
'YES' or 'NO'. Set all configured ISDN interfaces to
``up''. If isdn_interfaces is not blank, only the listed
interfaces will be modified. Used only if isdnd is set
kdc 'YES' or 'NO'. Runs the kdc(8) Kerberos v4 and v5
server. This should be run on Kerberos master and slave
rwhod 'YES' or 'NO'. Runs rwhod(8) to support the rwho(1) and
apmd 'YES' or 'NO'. Runs apmd(8) and passes apmd_flags.
moused 'YES' or 'NO'. Runs moused(8), to pass serial mouse data
to the wscons mouse mux. Passes moused_flags.
poffd 'YES' or 'NO'. Runs poffd(8) x68k shutdown daemon (only
for NetBSD/x68k). Passes poffd_flags.
screenblank 'YES' or 'NO'. Runs screenblank(1) and passes
wscons 'YES' or 'NO'. Configures the wscons(4) console driver,
from the configuration file /etc/wscons.conf.
wsmoused 'YES' or 'NO'. Runs wsmoused(8), to provide copy and
paste text support in wscons displays. Passes
/etc/rc.conf The file rc.conf resides in /etc.
/etc/defaults/rc.conf Default settings for rc.conf, sourced by rc.conf
before the end-user configuration section.
/etc/rc.conf.d/foo foo-specific rc.conf overrides.
boot(8), rc(8), rc.d(8), rc.subr(8), rcorder(8)
The rc.conf file appeared in NetBSD 1.3.
BSD January 15, 2004 BSD