PROTOCOLS(5) BSD File Formats Manual PROTOCOLS(5)
protocols -- protocol name database
The protocols file contains information regarding the known protocols
used in the DARPA Internet. For each protocol, a single line should be
present with the following information:
official protocol name
Items are separated by any number of blanks and/or tab characters.
A hash mark ('#') indicates the beginning of a comment; subsequent char-
acters up to the end of the line are not interpreted by the routines
which search the file.
Protocol names may contain any printable character other than a field
delimiter, newline, or comment character.
The protocols file format appeared in 4.2BSD.
A name server should be used instead of a static file. Lines in
/etc/protocols are limited to BUFSIZ characters (currently 1024). Longer
lines will be ignored.
BSD April 25, 2017 BSD