PHONES(5) OpenBSD Programmer's Manual PHONES(5)
phones - remote host phone number file
phones files are used by tip(1) to find phone numbers not included in the
remote(5) database(s) being used.
The default file is /etc/phones, which is used unless the PHONES environ-
ment variable has been set. /etc/phones is world readable by default,
and should not contain privileged information.
The format of the file is a series of lines of the form:
<system name>[ \t]*<phone number>
The system name must start at the first character on the line. The phone
number is any sequence of characters terminated by a `,' or the end of
the line. Thus the phone number field can contain arbitrary dialing
strings, not just phone numbers.
Certain auto-call units or modems can use `,' in their dialing strings.
For these units (currently Hayes, Courier and Telebit) tip(1) will trans-
late a `=' in the phone number to a `,' when actually dialing the number.
If the auto-call unit is a Racal-Vadic 831, tip(1) will translate a `_'
in the phone number to a `='.
tip(1) ignores all lines with a system name other than the one being
looked up. Comments can be inserted into the file by making the first
character on a line something not used to start any system name in the
remote(5) database(s) being used, such as `#'.
Only one phone number per line is permitted. To associate more than one
phone number with a system name you must create multiple lines that have
the same system name. tip(1) will try each number in sequence until it
makes a connection or reaches the end of the file.
/etc/phones The default phones file for tip(1).
The phones file appeared in 4.2BSD.
OpenBSD 3.6 June 5, 1993 1