openssl(5) Standards, Environments, and Macros openssl(5)
openssl - OpenSSL cryptographic & Secure Sockets Layer toolkit
OpenSSL is a crypography toolkit that implements the Secure Sockets
Layer (SSLv2/v3) and Transport Layer Security (TLS v1) network proto-
The following features are omitted from the binaries for issues includ-
ing but not limited to patents, trademark, and US export restrictions:
MDC2, RC3, RC5, IDEA, ECC, Dynamic Engine Loading, CSWIFT Engine, nCi-
pher Engine, Atalla Engine, NURON Engine, UBSEC Engine, AEP Engine,
Sureware Engine, and 4758_CCA Engine.
A new PKCS#11 engine has been included with ENGINE name "pkcs11".
The PKCS#11 engine is configured to use the Solaris Cryptographic
Framework. See cryptoadm(1M) for configuration information.
Due to requirements of the PKCS#11 standard regarding fork(2) behavior,
some applications that use the OpenSSL EVP interfaces and fork() with
active crypto contexts might experience unexpected behavior.
To build an OpenSSL application, use the following cc command line
cc [ flag... ] file... -I/usr/sfw/include -lcrypto -lssl \
-L/usr/sfw/lib -R/usr/sfw/lib [ library... ]
Extensive additional documentation for OpenSSL modules is available in
the /usr/sfw/share/man directory. This documentation can be viewed with
man(1) by including /usr/sfw/share/man in the MANPATH environment vari-
able. Running catman(1M) on the OpenSSL manual pages is not supported.
To view the license terms, attribution, and copyright for OpenSSL, see
See attributes(5) for a description of the following attributes:
tab() allbox; cw(2.750000i)| cw(2.750000i) lw(2.750000i)|
lw(2.750000i). ATTRIBUTE TYPEATTRIBUTE VALUE AvailabilitySUNWopensslr,
SUNWopenssl Interface StabilityExternal
cryptoadm(1M), libpkcs11(3LIB), attributes(5)
SunOS 5.10 22 Nov 2004 openssl(5)