NETWORKS(5) BSD File Formats Manual NETWORKS(5)
networks -- Internet Protocol network name database
The networks file is used as a local source to translate between Internet
Protocol (IP) network addresses and network names (and vice versa). It
can be used in conjunction with the Domain Name System (DNS).
While the networks file was originally intended to be an exhaustive list
of all IP networks that the local host could communicate with, distribu-
tion and update of such a list for the world-wide Internet (or, indeed,
for any large "enterprise" network) has proven to be prohibitive, so the
Domain Name System is used instead, except as noted.
For each IP network, a single line should be present with the following
official network name
ip network number
Items are separated by any number of blanks and/or tab characters.
A hash mark ('#') indicates the beginning of a comment; subsequent char-
acters up to the end of the line are not interpreted by routines which
search the file.
Network number may be specified in the conventional '.' (dot) notation
using the inet_addr(3) routine from the IP address manipulation library.
Network names may contain "a" through "z", zero through nine, and dash
IP network numbers on the Internet are generally assigned to a site by
its Internet Service Provider (ISP), who, in turn, get network address
space assigned to them by one of the regional Internet Registries (e.g.,
ARIN, RIPE NCC, APNIC). These registries, in turn, answer to the Inter-
net Assigned Numbers Authority (IANA).
If a site changes its ISP from one to another, it will generally be
required to change all its assigned IP addresses as part of the conver-
sion; that is, return the previous network numbers to the previous ISP
and assign addresses to its hosts from IP network address space given by
the new ISP. Thus, it is best for a savvy network manager to configure
his hosts for easy renumbering, to preserve his ability to easily change
his ISP should the need arise.
getnetent(3), resolver(3), resolv.conf(5), hostname(7), nsd(8),
P. Mockapetris, DNS Encoding of Network Names and Other Types, RFC 1101,
Y. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, and E. Lear,
Address Allocation for Private Internets, RFC 1918, February 1996.
H. Eidnes, G. de Groot, and P. Vixie, Classless IN-ADDR.ARPA delegation,
RFC 2317, March 1998.
V. Fuller and T. Li, Classless Inter-domain Routing (CIDR): The Internet
Address Assignment and Aggregation Plan, RFC 4632, August 2006.
The networks file format appeared in 4.2BSD.
BSD August 23, 2014 BSD