MYNAME(5) OpenBSD Programmer's Manual MYNAME(5)
myname, mygate - default hostname and gateway
The myname and mygate files are read by netstart(8) at system startup
/etc/myname contains the symbolic name of the host machine. The file
should contain a single line specifying the fully qualified domain name
(FQDN) of the system (e.g. host.example.com). The name must be resolv-
able, either by matching a hostname specified in /etc/hosts (see
hosts(5)) or through DNS (see resolv.conf(5)). The hostname is set via
the hostname(1) utility at boot time. See hostname(7) for a description
of hostname resolution.
/etc/mygate contains the address of the gateway host, if it exists. The
gateway is added to the routing tables by the route(8) utility. If
/etc/mygate does not exist, no default gateway is added to the routing
tables. The file should contain a single line specifying the gateway ad-
dress, in dotted quad notation (e.g. 192.0.2.0). /etc/mygate is pro-
cessed after all interfaces have been configured. It will therefore
override any DHCP-supplied default route information.
Neither file may contain comments.
/etc/myname Default hostname.
/etc/mygate Default gateway address.
hostname(1), hosts(5), resolv.conf(5), hostname(7), netstart(8), route(8)
This manual page first appeared in OpenBSD 3.4.
OpenBSD 3.6 July 24, 2003 1