MIXERCTL.CONF(5) BSD File Formats Manual MIXERCTL.CONF(5)
mixerctl.conf -- mixerctl configuration file
mixerctl.conf is the configuration file for mixerctl(1). It allows the
user to specify settings for the audio mixer at system startup. The
exact set of variables available are largely dependent on the audio
device driver, and vary from device to device. The file is made up of
variable assignments (name=value) with comments designated by a hash mark
Some audio devices have _sense variables which can help identify connec-
tors. The connectors' state will be one of plugged or unplugged, depend-
ing on whether a jack is inserted.
The connectors on audio cards are generally as follows:
pink Microphone in. Used to record from a microphone.
green Line out. Used for stereo speakers or headphones.
blue Line in. Used to record from an external source.
orange Speaker out; subwoofer.
brown Speaker out; rear speakers.
S/PDIF Optical connector; TOSLink, RCA, or 1/8" mini stereo.
Most devices have a number of digital to analogue converters (DACs), used
for sound playback, and each DAC has a corresponding output mixer. The
mixers are labelled ``mix'' or ``sel''. Each DAC represents two channels
Verify that playback works by playing an audio file (see aucat(1)) or CD
(see cdio(1)). Check that any relevant inputs.* variables are unmuted
and set to a high enough value to permit playback. For example, if play-
ing a CD, grep(1) for cd variables to adjust. Check also that the vari-
able governing the general audio level, such as outputs.master, is set to
a sufficiently high value.
Some cards are capable of multi-channel sound. In some cases _dir vari-
ables detail the direction (input or output) of the various connectors.
Check that the direction of the corresponding connectors is set to
output. Other devices may need to set _source variables to work cor-
rectly. The maximum possible value of the audioctl(1) variable
play.channels shows the number of channels available.
Most devices have a number of analogue to digital converters (ADCs), used
for recording sound, and each ADC has a corresponding input mixer. The
mixers are labelled ``mix'' or ``sel''. Each ADC represents two channels
Connect line in on the audio card to an audio source, such as an ampli-
fier. Many devices have an auxiliary connector (``aux'') available for
recording, or a headphone socket could be used.
Check that the variable that determines recording volume, such as
record.volume, is set high enough to provide a high enough sound level,
but not so high as to distort the sound being recorded. It is also a
good idea to mute any record.* variables not being used for recording.
Obviously the recording source itself will have to be unmuted.
A simple test that recording works may be done using aucat(1) whilst
playing back audio from an external source. The example below creates a
.wav file of any audio being played. The file can then be played back to
$ aucat -o test.wav
/dev/mixer Default audio mixing device.
/etc/mixerctl.conf mixerctl(1) configuration file.
aucat(1), audioctl(1), mixerctl(1)
BSD March 30, 2017 BSD