MAILER.CONF(5) BSD File Formats Manual MAILER.CONF(5)
mailer.conf -- configuration file for mailwrapper(8)
The file /etc/mailer.conf contains a series of pairs. The first member
of each pair is the name of a program invoking mailwrapper(8) which is
typically a symbolic link to /usr/sbin/sendmail. (On a typical system,
newaliases(8) and mailq(8) would be set up this way.) The second member
of each pair is the name of the program to actually execute when the
first name is invoked. The file may also contain comments, denoted by a
'#' character in the first column of any line.
The following is an example of how to set up mailer.conf for the default
smtpd(8) MTA suite .
# Emulate sendmail using smtpd
This example shows how to invoke the traditional sendmail(8) MTA suite in
place of smtpd(8).
# Execute the "real" sendmail program, named /usr/libexec/sendmail/sendmail
mail(1), mailq(8), mailwrapper(8), newaliases(8), smtpd(8)
Perry E. Metzger <firstname.lastname@example.org>
The entire reason this program exists is a crock. Instead, a command for
how to submit mail should be standardized, and all the "behave differ-
ently if invoked with a different name" behavior of things like mailq(8)
should go away.
BSD March 30, 2017 BSD