MAILER.CONF(5) OpenBSD Programmer's Manual MAILER.CONF(5)
mailer.conf - configuration file for mailwrapper(8)
The file /etc/mailer.conf contains a series of pairs. The first member
of each pair is the name of a program invoking mailwrapper(8) which is
typically a symbolic link to /usr/sbin/sendmail. (On a typical system,
newaliases(8) and mailq(8) would be set up this way.) The second member
of each pair is the name of the program to actually execute when the
first name is invoked. The file may also contain comments, denoted by a
`#' character in the first column of any line.
The following is an example of how to set up mailer.conf for traditional
sendmail(8) invocation behavior.
# Execute the "real" sendmail program, named /usr/libexec/sendmail/sendmail
This example shows how to invoke the postfix MTA suite in place of
# Emulate sendmail using postfix
mail(1), mailq(8), mailwrapper(8), newaliases(8), sendmail(8)
Perry E. Metzger <perryATpiermont.com>
The entire reason this program exists is a crock. Instead, a command for
how to submit mail should be standardized, and all the "behave different-
ly if invoked with a different name" behavior of things like mailq(8)
should go away.
OpenBSD 3.6 December 16, 1998 1