LKM.CONF(5) BSD File Formats Manual LKM.CONF(5)
lkm.conf -- loadable kernel module configuration file
The lkm.conf file specifies loadable kernel modules, see lkm(4), that are
to be loaded a boot time. The lkm.conf file is processed by /etc/rc.lkm
at system boot time, if it exists.
Each line of the file is of the form
path options entry postinstall output when
Except for the path, all other fields can be "-" to indicate empty.
The path is either an absolute pathname, or the name of a file in /lkm or
/usr/lkm that is the LKM to be loaded.
The options are some combination of the -d and -v options to modload(8).
The entry is the C symbol to call to initialize the module, defaulting to
The postinstall script is run after the LKM is installed.
The output of the ld(1) command is stored in output.
The when field specifies at which time in the startup process the LKM is
loaded. There are three predefined values which correspond to three
points in the processing of the system startup script /etc/rc:
Before networking is started. This works only if the /usr file sys-
tem can already be mounted at this time.
Before all file systems listed in /etc/fstab are mounted (the /usr
and /var file systems are already present).
After all file systems are mounted.
A "-" entry defaults to BEFORENET.
/etc/lkm.conf, /etc/rc, /etc/rc.d/lkm, /etc/rc.lkm
The lkm.conf file appeared in NetBSD 1.3.
BSD November 8, 2000 BSD