HOSTS(5) BSD File Formats Manual HOSTS(5)
hosts -- host name database
The hosts file contains information regarding the known hosts on the net-
work. For each host, a single line should be present with the following
Official host name
Items are separated by any number of blanks and/or tab characters. A '#'
indicates the beginning of a comment; characters up to the end of the
line are not interpreted by routines which search the file.
The system configuration file resolv.conf(5) controls where host name
information will be searched for. The mechanism provided permits the
administrator to describe the databases to search; the databases cur-
rently known include yp(8), DNS and the hosts database.
When using a name server this file provides a backup when the name server
is not running. For the name server, it is suggested that only a few
addresses be included in this file. These include addresses for the
local interfaces that ifconfig(8) needs at boot time and a few machines
on the local network.
Internet addresses are specified using either dot notation (IPv4) or
colon separated notation (IPv6). Further information on network address-
ing is contained in inet_addr(3). Host names may contain any printable
character other than a field delimiter, newline, or comment character.
getaddrinfo(3), gethostbyname(3), getnameinfo(3), inet_addr(3),
resolv.conf(5), ifconfig(8), nsd(8), unbound(8)
The hosts file format appeared in 4.2BSD.
An official host database used to be maintained at the Network Informa-
tion Control Center (NIC).
A name server should be used instead of a static file.
Lines in /etc/hosts are limited to BUFSIZ characters (currently 1024).
Longer lines will be ignored.
BSD May 29, 2017 BSD