HOSTS(5) OpenBSD Programmer's Manual HOSTS(5)
hosts - host name database
The hosts file contains information regarding the known hosts on the net-
work. For each host, a single line should be present with the following
Official host name
Items are separated by any number of blanks and/or tab characters. A `#'
indicates the beginning of a comment; characters up to the end of the
line are not interpreted by routines which search the file.
The system configuration file resolv.conf(5) controls where host name in-
formation will be searched for. The mechanism provided permits the ad-
ministrator to describe the databases to search; the databases currently
known include yp(8), DNS and the hosts database.
When using the name server named(8), this file provides a backup when the
name server is not running. For the name server, it is suggested that
only a few addresses be included in this file. These include addresses
for the local interfaces that ifconfig(8) needs at boot time and a few
machines on the local network.
This file may be created from the official host database maintained at
the Network Information Control Center (NIC), though local changes may be
required to bring it up to date regarding unofficial aliases and/or un-
known hosts. As the database maintained at NIC is incomplete, use of the
name server is recommended for sites on the DARPA Internet.
Network addresses are specified in the conventional Internet ``.'' (dot)
notation using the inet_addr(3) routine from the Internet address manipu-
lation library, inet(3). Host names may contain any printable character
other than a field delimiter, newline, or comment character.
getaddrinfo(3), gethostbyname(3), getnameinfo(3), resolv.conf(5),
Name Server Operations Guide for BIND.
The hosts file format appeared in 4.2BSD.
A name server should be used instead of a static file.
Lines in /etc/hosts are limited to BUFSIZ characters (currently 1024).
Longer lines will be ignored.
OpenBSD 3.6 December 11, 1993 1