HOSTS(5) BSD File Formats Manual HOSTS(5)
hosts -- host name data base
The hosts file contains information regarding the known hosts on the net-
work. It can be used in conjunction with the DNS, and the NIS maps
'hosts.byaddr', and 'hosts.byname', as controlled by nsswitch.conf(5).
For each host a single line should be present with the following informa-
address hostname [alias ...]
address Internet address
hostname Official host name
alias Alias host name
Items are separated by any number of blanks and/or tab characters. A
hash sign (``#'') indicates the beginning of a comment; characters up to
the end of the line are not interpreted by routines which search the
When using the name server named(8), or ypserv(8), this file provides a
backup when the name server is not running. For the name server, it is
suggested that only a few addresses be included in this file. These
include address for the local interfaces that ifconfig(8) needs at boot
time and a few machines on the local network.
This file may be created from the official host data base maintained at
the Network Information Control Center (NIC), though local changes may be
required to bring it up to date regarding unofficial aliases and/or
unknown hosts. As the data base maintained at NIC is incomplete, use of
the name server is recommended for sites on the DARPA Internet.
As network addresses, both IPv4 and IPv6 addresses are allowed. IPv4
addresses are specified in the conventional dot (``.'') notation using
the inet_pton(3) routine from the Internet address manipulation library,
inet(3). IPv6 addresses are specified in the standard hex-and-colon
notation. Host names may contain any printable character other than a
field delimiter, newline, or comment character.
/etc/hosts The hosts file resides in /etc.
gethostbyname(3), nsswitch.conf(5), ifconfig(8), named(8)
Name Server Operations Guide for BIND.
The hosts file format appeared in 4.2BSD.
BSD November 17, 2000 BSD