GETTYTAB(5) BSD File Formats Manual GETTYTAB(5)
gettytab -- terminal configuration database
The gettytab file is a simplified version of the termcap(5) database used
to describe terminal lines. The initial terminal login process getty(8)
accesses the gettytab file each time it starts, allowing simpler recon-
figuration of terminal characteristics. Each entry in the database is
used to describe one class of terminals.
There is a default terminal class, default, that is used to set global
defaults for all other classes. (That is, the default entry is read,
then the entry for the class required is used to override particular set-
Refer to termcap(5) for a description of the file layout. The default
column below lists defaults obtained if there is no entry in the table
obtained, nor one in the special default table.
Name Type Default Description
ap bool false Terminal uses any parity.
bk str 0377 Alternative end-of-line character (input
c0 num unused TTY control flags to write messages.
c1 num unused TTY control flags to read login name.
c2 num unused TTY control flags to leave terminal as.
ce bool false Use CRT erase algorithm.
ck bool false Use CRT kill algorithm.
cl str NULL Screen clear sequence.
co bool false Console; add '\n' after login prompt.
ds str '^Y' Delayed suspend character.
dx bool false Set DECCTLQ.
ec bool false Leave echo OFF.
ep bool false Terminal uses even parity.
er str '^?' Erase character.
et str '^D' End of text (EOF) character.
ev str NULL Initial environment.
fl str '^O' Output flush character.
hc bool false Do not hangup line on last close.
he str NULL Hostname editing string.
hn str hostname Hostname.
ht bool false Terminal has real tabs.
i0 num unused TTY input flags to write messages.
i1 num unused TTY input flags to read login name.
i2 num unused TTY input flags to leave terminal as.
ig bool false Ignore garbage characters in login name.
im str NULL Initial (banner) message.
in str '^C' Interrupt character.
is num unused Input speed.
kl str '^U' Kill character.
l0 num unused TTY local flags to write messages.
l1 num unused TTY local flags to read login name.
l2 num unused TTY local flags to leave terminal as.
lc bool false Terminal has lower case.
lm str login: Login prompt.
ln str '^V' ``Literal next'' character.
lo str /usr/bin/login Program to execute when name
mb bool false Do flow control based on carrier.
nl bool false Terminal has (or might have) a newline
np bool false Terminal uses no parity (i.e., 8-bit
nx str default Next table (for auto speed selection).
o0 num unused TTY output flags to write messages.
o1 num unused TTY output flags to read login name.
o2 num unused TTY output flags to leave terminal as.
op bool false Terminal uses odd parity.
os num unused Output speed.
pc str '\0' Pad character.
pe bool false Use printer (hard copy) erase algorithm.
pf num 0 Delay between first prompt and following flush
pp str unused PPP authentication program.
ps bool false Line connected to a MICOM port selector.
qu str '^\' Quit character.
rp str '^R' Line retype character.
rw bool false Do not use raw for input, use cbreak.
sp num unused Line speed (input and output).
su str '^Z' Suspend character.
tc str none Table continuation.
to num 0 Timeout (seconds).
tt str NULL Terminal type (for environment).
ub bool false Do unbuffered output (of prompts etc).
we str '^W' Word erase character.
xc bool false Do not echo control characters as '^X'.
xf str '^S' XOFF (stop output) character.
xn str '^Q' XON (start output) character.
The following capabilities are no longer supported by getty(8):
bd num 0 Backspace delay.
cb bool false Use CRT backspace mode.
cd num 0 Carriage-return delay.
f0 num unused TTY mode flags to write messages.
f1 num unused TTY mode flags to read login name.
f2 num unused TTY mode flags to leave terminal as.
fd num 0 Form-feed (vertical motion) delay.
nd num 0 Newline (line-feed) delay.
uc bool false Terminal is known upper case only.
If no line speed is specified, speed will not be altered from that which
prevails when getty(8) is entered. Specifying an input or output speed
will override line speed for stated direction only.
Terminal modes to be used for the output of the message and for input of
the login name, and to leave the terminal set as upon completion, are
derived from the boolean flags specified. If the derivation should prove
inadequate, any (or all) of these three may be overridden with one of the
c0, c1, c2, i0, i1, i2, l0, l1, l2, o0, o1, or o2 numeric specifications,
which can be used to specify (usually in octal, with a leading '0') the
exact values of the flags. These flags correspond to the termios
c_cflag, c_iflag, c_lflag, and c_oflag fields, respectively. Each of
these sets must be completely specified to be effective.
Should getty(8) receive a null character (presumed to indicate a line
break) it will restart using the table indicated by the nx entry. If
there is none, it will re-use its original table.
Delays are specified in milliseconds; the nearest possible delay avail-
able in the TTY driver will be used. Should greater certainty be
desired, delays with values 0, 1, 2, and 3 are interpreted as choosing
that particular delay algorithm from the driver.
The cl screen clear string may be preceded by a (decimal) number of mil-
liseconds of delay required (a la termcap(5)). This delay is simulated
by repeated use of the pad character pc.
The initial message and login message (im and lm) may include any of the
following character sequences, which expand to information about the
environment in which getty(8) is running:
%d The current date.
%h The hostname of the machine, which is normally obtained from the
system using gethostname(3), but may also be overridden by the hn
table entry. In either case it may be edited with the he string.
A '@' in the he string causes one character from the real hostname
to be copied to the final hostname. A '#' in the he string causes
the next character of the real hostname to be skipped. Each char-
acter that is neither '@' nor '#' is copied into the final host-
name. Surplus '@' and '#' characters are ignored.
%t The TTY name.
%m, %r, %s, %v
The type of machine, release of the operating system, name of the
operating system, and version of the kernel, respectively, as
returned by uname(3).
%% A '%' character.
When getty(8) executes the login process given in the lo string (usually
/usr/bin/login), it will have set the environment to include the terminal
type, as indicated by the tt string (if it exists). The ev string can be
used to enter additional data into the environment. It is a list of
comma-separated strings, each of which will presumably be of the form
If a non-zero timeout is specified with to, then getty(8) will exit
within the indicated number of seconds, either having received a login
name and passed control to login(1), or having received an alarm signal
and exited. This may be useful to hangup dial in lines.
Output from getty(8) is even parity unless op or np is specified. The op
string may be specified with ap to allow any parity on input, but gener-
ate odd parity output. Note: this only applies while getty(8) is being
run; terminal driver limitations prevent a more complete implementation.
getty(8) does not check parity of input characters in RAW mode.
If a pp string is specified and a PPP link bring-up sequence is recog-
nized, getty(8) will invoke the program referenced by the pp option.
This can be used to handle incoming PPP calls.
login(1), gethostname(3), uname(3), termcap(5), getty(8)
The gettytab file format appeared in 4.2BSD.
The special characters (erase, kill, etc.) are reset to system defaults
by login(1). In all cases, '#' or '^H' typed in a login name will be
treated as an erase character, and '@' will be treated as a kill charac-
The delay stuff is a real crock. Apart from its general lack of flexi-
bility, some of the delay algorithms are not implemented. The terminal
driver should support sane delay settings.
The he capability is stupid.
The termcap(5) format is horrid; something more rational should have been
BSD May 24, 2014 BSD