DM.CONF(5) BSD File Formats Manual DM.CONF(5)
dm.conf -- dungeon master configuration file
The dm.conf file is the configuration file for the dm(8) program. It
consists of lines beginning with one of three keywords, badtty, game, and
time. All other lines are ignored.
Any tty listed after the keyword badtty may not have games played on it.
Entries consist of two white-space separated fields: the string badtty
and the ttyname as returned by ttyname(3). For example, to keep the uucp
dialout, ``tty19'', from being used for games, the entry would be:
Any day/hour combination listed after the keyword time will disallow
games during those hours. Entries consist of four white-space separated
fields: the string time, the unabbreviated day of the week and the begin-
ning and ending time of a period of the day when games may not be played.
The time fields are in a 0 based, 24-hour clock. For example, the fol-
lowing entry allows games playing before 8AM and after 5PM on Mondays:
time Monday 8 17
Any game listed after the keyword game will set parameters for a specific
game. Entries consist of five white-space separated fields: the keyword
game, the name of a game, the highest system load average at which the
game may be played, the maximum users allowed if the game is to be
played, and the priority at which the game is to be run. Any of these
fields may start with a non-numeric character, resulting in no game limi-
tation or priority based on that field.
The game default controls the settings for any game not otherwise listed,
and must be the last game entry in the file. Priorities may not be nega-
tive. For example, the following entries limits the game ``hack'' to
running only when the system has 10 or less users and a load average of 5
or less; all other games may be run any time the system has 15 or less
game hack 5 10 *
game default * 15 *
/etc/dm.conf The dm(8) configuration file.
setpriority(2), ttyname(3), dm(8)
BSD May 31, 1993 BSD