DHCLIENT.LEASES(5) OpenBSD Programmer's Manual DHCLIENT.LEASES(5)
dhclient.leases - DHCP client lease database
The Internet Software Consortium DHCP client keeps a persistent database
of leases that it has acquired that are still valid. The database is a
free-form ASCII file containing one valid declaration per lease. If more
than one declaration appears for a given lease, the last one in the file
is used. The file is written as a log, so this is not an unusual occur-
The lease file is named "dhclient.leases.IFNAME", where "IFNAME" repre-
sents the network interface the DHCP client acquired the lease on. For
example, if dhclient(8) is configured for the em0 network device, the
lease file will be named "dhclient.leases.em0".
The format of the lease declarations is described in dhclient.conf(5).
/var/db/dhclient.leases.IFNAME Current lease file.
dhclient.conf(5), dhcp-options(5), dhcpd.conf(5), dhclient(8), dhcpd(8)
RFC 2132, RFC 2131.
dhclient(8) was written by Ted Lemon <mellonATvix.com> under a contract
with Vixie Labs.
The current implementation was reworked by
Henning Brauer <henningATopenbsd.org>.
OpenBSD 3.6 January 1, 1997 1