DAILY.CONF(5) BSD File Formats Manual DAILY.CONF(5)
daily.conf -- daily maintenance configuration file
The daily.conf file specifies which of the standard /etc/daily services
are performed. The /etc/daily script is run, by default, every night on
a NetBSD system.
The variables described below can be set to ``YES'' or ``NO'' in the
/etc/daily.conf file. Most default to ``YES'', but not all. Check the
/etc/defaults/daily.conf file if you are in doubt. (Note that you should
never edit /etc/defaults/daily.conf directly, as it is often replaced
during system upgrades.)
find_core This runs find(1) over the entire local filesystem,
looking for core files.
run_msgs This runs msgs(1) with the -c argument.
expire_news This runs the /etc/expire.news script.
purge_accounting This ages accounting files in /var/account.
run_calendar This runs calendar(1) with the -a argument.
check_uucp This runs the /etc/uuclean.daily script, as the daemon
user, and runs uustat(1) with the -a argument.
check_disks This uses the df(1) and dump(8) to give disk status,
and also reports failed raid(4) components.
show_remote_fs In check_disks, show remote file systems, which are not
reported on by default.
check_mailq This runs mailq(1).
check_network This runs netstat(1) with the -i argument, and also
checks the rwhod(8) database, and runs ruptime(1) if
there are hosts in /var/rwho.
full_netstat By default, check_network outputs a summarized version
of the netstat(1) report. If a full version of the
output run with the -inv options is desired, set this
run_fsck This runs fsck(8) with the -n option.
run_rdist This runs rdist(1) with /etc/Distfile.
run_security This runs the /etc/security script looking for possible
security problems with the system.
run_skeyaudit Runs the skeyaudit(1) program to check the S/Key data-
base and informs users of S/Keys that are about to
The variables described below can be set to modify the tests:
If set, the report generated by the run_security phase
will always be sent, even if it is empty.
/etc/daily daily maintenance script
/etc/daily.conf daily maintenance configuration
/etc/defaults/daily.conf default settings, overridden by /etc/daily.conf
/etc/daily.local local site additions to /etc/daily
monthly.conf(5), security.conf(5), weekly.conf(5)
The daily.conf file appeared in NetBSD 1.3.
BSD December 8, 2003 BSD