CORE(5) BSD File Formats Manual CORE(5)
core -- memory image file format
A small number of signals which cause abnormal termination of a process
also cause a record of the process's in-core state to be written to disk
for later examination by one of the available debuggers. (See
sigaction(2).) This memory image is written to a file named by default
core.pid in the /cores directory; provided the terminated process had
write permission in the directory, and the directory existed.
The maximum size of a core file is limited by setrlimit(2). Files which
would be larger than the limit are not created.
The core file consists of the ~ Mach-O(5) header as described in the
<mach-o/loader.h> file. The remainder of the core file consists of vari-
ous sections described in the Mach-O(5) header.
Core dumps are disabled by default under Darwin/Mac OS X. To re-enable
core dumps, a privlaged user must edit /etc/hostconfig to contain the
gdb(1), setrlimit(2), sigaction(2), Mach-O(5), sysctl(8)
A core file format appeared in Version 6 AT&T UNIX.
BSD March 18, 2002 BSD