ALIASES(5) BSD File Formats Manual ALIASES(5)
aliases -- aliases file for smtpd
This manual page describes the format of the aliases file, as used by
smtpd(8). An alias in its simplest form is used to assign an arbitrary
name to an email address, or a group of email addresses. This provides a
convenient way to send mail. For example an alias could refer to all
users of a group: email to that alias would be sent to all members of the
group. Much more complex aliases can be defined however: an alias can
refer to other aliases, be used to send mail to a file instead of another
person, or to execute various commands.
Within the file, '#' is a comment delimiter; anything placed after it is
discarded. The file consists of key/value mappings of the form:
key: value1, value2, value3, ...
key is always folded to lowercase before alias lookups to ensure that
there can be no ambiguity. The key is expanded to the corresponding val-
ues, which consist of one or more of the following:
user A user on the host machine. The user must have a valid entry in
the passwd(5) database file.
Append messages to file, specified by its absolute pathname.
Pipe the message to command on its standard input. The command
is run under the privileges of the daemon's unprivileged account.
Include any definitions in file as alias entries. The format of
the file is identical to this one.
An email address in RFC 5322 format (see mailaddr(7)). If an
address extension is appended to the user-part, it is stripped so
that an address such as user+extATexample.com will only use the
part that precedes '+' as a key.
A status code and message to return. The code must be 3 digits,
starting 4XX (TempFail) or 5XX (PermFail). The message must be
present and can be freely chosen.
/etc/mail/aliases Default aliases file.
smtpd.conf(5), makemap(8), newaliases(8), smtpd(8)
The aliases file format appeared in 4.0BSD.
BSD March 23, 2017 BSD