ALIASES(5) OpenBSD Programmer's Manual ALIASES(5)
aliases - aliases file for sendmail
This file describes user ID aliases used by /usr/sbin/sendmail. The file
resides in /etc/mail and is formatted as a series of lines of the form
name: addr_1, addr_2, addr_3, . . .
The name is the name to alias, and the addr_n are the aliases for that
name. addr_n can be another alias, a local username, a local filename, a
command, an include file, or an external address.
The username must be available via getpwnam(3).
Messages are appended to the file specified by the full pathname
(starting with a slash (/))
A command starts with a pipe symbol (|), it receives messages via stan-
The aliases in pathname are added to the aliases for name.
An e-mail address in RFC 822 format.
Lines beginning with whitespace are continuation lines. Another way to
continue lines is by placing a backslash directly before a newline.
Lines beginning with `#' are comments.
Aliasing occurs only on local names. Loops can not occur, since no mes-
sage will be sent to any person more than once.
After aliasing has been done, local and valid recipients who have a
``.forward'' file in their home directory have messages forwarded to the
list of users defined in that file.
This is only the raw data file; the actual aliasing information is placed
into a binary format in the file /etc/mail/aliases.db using the program
newaliases(8). A newaliases command should be executed each time the
aliases file is changed for the change to take effect.
dbm(3), dbopen(3), newaliases(8), sendmail(8)
Sendmail Installation and Operation Guide, No. 8, SMM.
Sendmail - An Internetwork Mail Router, No. 9, SMM.
The aliases file format appeared in 4.0BSD.
If you have compiled sendmail with DBM support instead of NEWDB, you may
have encountered problems in dbm(3) restricting a single alias to about
1000 bytes of information. You can get longer aliases by ``chaining'';
that is, make the last name in the alias be a dummy name which is a con-
OpenBSD 3.6 December 14, 2000 2