ZYD(4) BSD Kernel Interfaces Manual ZYD(4)
zyd -- ZyDAS ZD1211/ZD1211B USB IEEE 802.11b/g wireless network device
zyd* at uhub? port ?
The zyd driver provides support for wireless network adapters based
around the ZyDAS ZD1211 and ZD1211B USB chips.
These are the modes the zyd driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The zyd driver can be configured to use Wired Equivalent Privacy (WEP) or
Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it. The zyd driver relies on the
software 802.11 stack for both encryption and decryption of data frames.
The zyd driver can be configured at runtime with ifconfig(8) or on boot
The following devices are known to be supported by the zyd driver:
Airlink 101 AWLL3026
AOpen 802.11g WL54
Asus A9T integrated wireless
Belkin F5D7050 v.4000
Billion BiPAC 3011G
DrayTek Vigor 550
Fiberline Networks WL-43OU
Sagem XG 760A
Sagem XG 76NA
Sandberg Wireless G54 USB
Sweex wireless USB 54 Mbps
Tekram/Siemens USB adapter
Trendnet TEW-424UB rev A
US Robotics 5423
Yakumo QuickWLAN USB
ZyXEL AG-225H v2
ZyXEL G-200 v2
The adapter needs some firmware files, which are loaded on demand by the
driver when a device is attached:
The following example scans for available networks:
# ifconfig zyd0 scan
The following hostname.if(5) example configures zyd0 to join network
``mynwid'', using WPA key ``mywpakey'', obtaining an IP address using
zyd0: error N, could not read firmware ... For some reason, the driver
was unable to read the firmware image from the filesystem. The file
might be missing or corrupted.
zyd0: could not load firmware (error=N) An error occurred while attempt-
ing to upload the firmware to the onboard microcontroller unit.
zyd0: could not send command (error=...) An attempt to send a command to
the firmware failed.
zyd0: sorry, radio ... is not supported yet Support for the specified
radio chip is not yet implemented in the driver. The device will not
zyd0: device version mismatch: 0xXXXX (only >>= 43.30 supported) Early
revisions of the ZD1211 chipset are not supported by this driver. The
device will not attach.
zyd0: device timeout A frame dispatched to the hardware for transmission
did not complete in time. The driver will reset the hardware. This
should not happen.
arp(4), ifmedia(4), intro(4), netintro(4), usb(4), hostname.if(5),
The zyd driver was written by Florian Stoehr <email@example.com>,
Damien Bergamini <firstname.lastname@example.org>, and Jonathan Gray
The zyd driver does not support a lot of the functionality available in
the hardware. More work is required to properly support the IBSS and
power management features.
BSD March 30, 2017 BSD