YM(4) BSD Kernel Interfaces Manual YM(4)
ym -- Yamaha OPL3-SAx audio device
ym* at isapnp?
midi* at ym?
audio* at ym?
The ym driver provides support for Yamaha OPL3-SAx chipset-based cards.
audio(4), intro(4), isapnp(4), midi(4), wss(4)
This driver is a thin wrapper around the wss(4) driver. The ym device
driver appeared in OpenBSD 2.4.
The "FM" DAC, wavetable synth, and MIDI port are not supported. I can't
seem to access any of the extended registers so master volume, mute, 3-d
control might not work through the mixer interface. Lots of work needed.
BSD March 28, 2017 BSD