WSKBD(4) BSD Kernel Interfaces Manual WSKBD(4)
wskbd -- generic keyboard support in wscons
wskbd* at ...
The wskbd driver handles common tasks for keyboards within the wscons(4)
framework. It is attached to the hardware specific keyboard drivers and
provides their connection to ``wsdisplay'' devices and a character device
The common keyboard support consists of:
o Mapping from keycodes (defined by the specific keyboard driver) to
keysyms (hardware independent, defined in
o Handling of ``compose'' sequences. Characters commonly not present
as separate keys on keyboards can be generated after either a special
``compose'' key is pressed or a ``dead accent'' character is used.
o Certain translations, like turning an ``ALT'' modifier into an
o Automatic key repetition (``typematic'').
o Parameter handling for ``keyboard bells''.
o Generation of ``keyboard events'' for use by X servers.
The wskbd driver provides a number of ioctl functions to control key maps
and other parameters. These functions are accessible through the associ-
ated ``wsdisplay'' device as well. A complete list is in
/usr/include/dev/wscons/wsconsio.h. The wsconsctl(8) utility allows
access to key maps and other variables.
The console locator in the configuration line refers to the device's use
as input part of the operating system console. A device specification
containing a positive value here will only match if the device is in use
as system console. (The console device selection in early system startup
is not influenced.) This way, the console device can be connected to a
known wskbd device instance.
The wskbd driver traps certain key sequences intended to perform special
functions. The Ctrl+Alt+Esc sequence will initiate the ddb(4) kernel
debugger if the ``ddb.console'' sysctl(8) variable is set. When attached
to a wsdisplay(4) device, Ctrl+Alt+Fx switches virtual terminals and the
Shift+PgUp and Shift+PgDn combinations provide scrollback functionality
if the underlying hardware driver supports it. When audio devices are
supported, keys Mute, VolumeUp and VolumeDown tweak mixer settings.
akbd(4), comkbd(4), hilkbd(4), intro(4), lkkbd(4), pckbd(4), ukbd(4),
wscons(4), wsmux(4), zkbd(4), zrc(4), zskbd(4), wsconsctl(8)
BSD March 30, 2017 BSD