WPI(4) BSD Kernel Interfaces Manual WPI(4)
wpi -- Intel PRO/Wireless 3945ABG IEEE 802.11a/b/g wireless network
wpi* at pci?
The wpi driver provides support for Intel PRO/Wireless 3945ABG Mini PCI
Express network adapters.
These are the modes the wpi driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The wpi driver can be configured to use Wired Equivalent Privacy (WEP) or
Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it. The wpi driver offloads both
encryption and decryption of unicast data frames to the hardware for the
The wpi driver can be configured at runtime with ifconfig(8) or on boot
The driver needs at least version 3.1 of the following firmware file,
which is loaded when an interface is brought up:
This firmware file is not free because Intel refuses to grant distribu-
tion rights without contractual obligations. As a result, even though
OpenBSD includes the driver, the firmware file cannot be included and
users have to download this file on their own.
A prepackaged version of the firmware can be installed using
The following example scans for available networks:
# ifconfig wpi0 scan
The following hostname.if(5) example configures wpi0 to join network
``mynwid'', using WPA key ``mywpakey'', obtaining an IP address using
wpi0: device timeout A frame dispatched to the hardware for transmission
did not complete in time. The driver will reset the hardware. This
should not happen.
wpi0: fatal firmware error For some reason, the firmware crashed. The
driver will reset the hardware. This should not happen.
wpi0: Radio transmitter is off The radio transmitter is off and thus no
packet can go out. The driver will reset the hardware. Make sure the
laptop radio switch is on.
wpi0: error N, could not read firmware ... For some reason, the driver
was unable to read the firmware image from the filesystem. The file
might be missing or corrupted.
wpi0: firmware file too short: N bytes The firmware image is corrupted
and can't be loaded into the adapter.
wpi0: could not load firmware An attempt to load the firmware into the
adapter failed. The driver will reset the hardware.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5),
The wpi driver was written by Damien Bergamini
BSD March 28, 2017 BSD