WLAN(4) BSD Kernel Interfaces Manual WLAN(4)
wlan -- generic 802.11 link-layer support
The wlan device provides generic code to support 802.11 drivers, includ-
ing host AP mode. Currently it is required for the wi(4), an(4) and
ath(4) drivers but will eventually be required by all 802.11 drivers.
If the associated interface is marked for debugging with, for example,
ifconfig wi0 debug
then messages describing the operation of the 802.11 protocol will be
sent to the console. With the interface marked for debugging, doing:
causes additional messages to be generated. Many drivers will also dis-
play the contents of each 802.11 frame sent and received when the inter-
face is marked with both debugging and link2; e.g.,
ifconfig wi0 debug link2
Beware however that some management frames may be processed entirely
within the device and not be received by the host.
The module name of wlan was used to be compatible with NetBSD.
an(4), ath(4), awi(4), netintro(4), wi(4)
More information can be found in the IEEE 802.11 Standard.
The wlan driver first appeared in FreeBSD 5.0.
Atsushi Onoe is the original author of this software. The NetBSD support
was adapted to FreeBSD by Sam Leffler. This manual page was written by
Tom Rhodes <trhodesATFreeBSD.org>.
BSD September 25, 2003 BSD