WB(4) BSD Kernel Interfaces Manual WB(4)
wb -- Winbond W89C840F 10/100 Ethernet device
wb* at pci?
amphy* at mii?
The wb driver provides support for PCI Ethernet adapters and embedded
controllers based on the Winbond W89C840F Fast Ethernet controller chip.
This includes the TRENDnet TE100-PCIE and various other cheap boards.
The 840F should not be confused with the 940F, which is an NE2000 clone
and only supports 10Mbps speeds.
The Winbond controller uses bus master DMA and is designed to be a DEC
"tulip" work-alike. It differs from the standard DEC design in several
ways: the control and status registers are spaced 4 bytes apart instead
of 8, and the receive filter is programmed through registers rather than
by downloading a special setup frame via the transmit DMA engine. Using
an external PHY, the Winbond chip supports both 10 and 100Mbps speeds in
either full or half duplex.
The wb driver supports the following media types:
autoselect Enable autoselection of the media type and options. This is
only supported if the PHY chip attached to the Winbond con-
troller supports NWAY autonegotiation. The user can manu-
ally override the autoselected mode by adding media options
to the appropriate hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
The wb driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
Note that the 100baseTX media type is only available if supported by the
adapter. For more information on configuring this device, see
wb0: couldn't map memory A fatal initialization error has occurred.
wb0: couldn't map interrupt A fatal initialization error has occurred.
wb0: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
wb0: no memory for rx list The driver failed to allocate an mbuf for the
wb0: no memory for tx list The driver failed to allocate an mbuf for the
transmitter ring when allocating a pad buffer or collapsing an mbuf chain
into a cluster.
amphy(4), arp(4), ifmedia(4), intro(4), netintro(4), pci(4),
The wb device driver first appeared in FreeBSD 3.0. OpenBSD support
first appeared in OpenBSD 2.5.
The wb driver was written by Bill Paul <email@example.com>.
The Winbond chip seems to behave strangely in some cases when the link
partner switches modes. If, for example, both sides are set to 10Mbps
half-duplex, and the other end is changed to 100Mbps full-duplex, the
Winbond's receiver suddenly starts writing trash all over the RX descrip-
tors. The wb driver handles this by forcing a reset of both the con-
troller chip and attached PHY. This is drastic, but it appears to be the
only way to recover properly from this condition.
BSD July 16, 2013 BSD