VR(4) BSD Kernel Interfaces Manual VR(4)
vr -- VIA Rhine I/II/III 10/100 Ethernet device
vr* at pci?
amphy* at mii?
icsphy* at mii?
sqphy* at mii?
The vr driver provides support for PCI Ethernet adapters and embedded
controllers based on the VIA Technologies VT3043 Rhine I, VT86C100A Rhine
II, VT6102 Rhine II, and VT6105/VT6105M Rhine III Fast Ethernet con-
troller chips, including the following:
o AOpen/Acer ALN-320
o D-Link DFE-520TX, DFE-530TX
o Hawking Technologies PN102TX
o Soekris Engineering lan1741
The VIA Rhine chips use bus master DMA and have a software interface
designed to resemble that of the DEC 21x4x "tulip" chips. The major dif-
ferences are that the receive filter in the Rhine chips is much simpler
and is programmed through registers rather than by downloading a special
setup frame through the transmit DMA engine, and that on older chips
transmit and receive DMA buffers must be longword aligned. The Rhine
chips are meant to be interfaced with external physical layer devices via
an MII bus. They support both 10 and 100Mbps speeds in either full or
The vr driver for the VT6105M controller supports IPv4 IP/TCP/UDP trans-
mit/receive checksum offload and VLAN tag insertion and stripping. The
vr driver additionally supports Wake on LAN (WoL). See arp(8) and
ifconfig(8) for more details.
The vr driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to the appropriate hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
The vr driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
Note that the 100baseTX media type is only available if supported by the
For more information on configuring this device, see ifconfig(8).
vr0: couldn't map memory A fatal initialization error has occurred.
vr0: couldn't map interrupt A fatal initialization error has occurred.
vr0: watchdog timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
vr0: no memory for rx list The driver failed to allocate an mbuf for the
vr0: no memory for tx list The driver failed to allocate an mbuf for the
transmitter ring when allocating a pad buffer or collapsing an mbuf chain
into a cluster.
amphy(4), arp(4), icsphy(4), ifmedia(4), intro(4), netintro(4), pci(4),
sqphy(4), hostname.if(5), ifconfig(8)
The VIA Technologies VT86C100A data sheet, http://www.via.com.tw.
The vr device driver first appeared in FreeBSD 3.0. OpenBSD support
first appeared in OpenBSD 2.5.
The vr driver was written by Bill Paul <firstname.lastname@example.org>.
The vr driver copies transmit mbuf chains into longword-aligned buffers
prior to transmission in order to pacify the VT3043 and VT86C100A chips.
If buffers are not aligned correctly, the chip will round the supplied
buffer address and begin DMAing from the wrong location. This buffer
copying impairs transmit performance on slower systems but can't be
avoided. On faster machines (e.g., a Pentium II), the performance impact
is much less noticeable.
BSD April 26, 2017 BSD